6.4 p2263 overboosting no power - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-25-2013, 06:16 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: ontario
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.4 p2263 overboosting no power

i have a 2008 6.4 egr delete, dpf delete, running a minimaxx, once it got cold out it starting acting up, i change the ebp sensor the other day...Ill be driving down the road doing 70km/h the truck will hit 40psi boost without bareley hitting the throttle and it sounds like my boost is spilling out....i still get the p2563 ebp code here and there but then i get the turbo circuit performance code...any suggestions??? i booked an appointment with ford because sudposeably they can trouble shoot whats causing the code with their computer??? true or false??? i need some help ive been down for over a month
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-25-2013, 06:54 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,223
Thanks: 14
Thanked 63 Times in 62 Posts
Feedback Score: 0 reviews
You should replace the map sensor. Did you clean the ebp tube when you replaced it? This should get rid of your problem.
Reply With Quote Quick reply to this message
  #3  
Old 01-25-2013, 06:58 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: ontario
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah i took the ebp tube off and cleaned it too, i havent changed the map sensor though, im going too go order one today forsure, i sprayed water and soap lastnight around my turbos too see if there was any serious leak, i had some bubbles coming out around the acctuator arm, but nothing major.....its hard too tell if theres anything air leaks with the truck running, im going too go into ford and get a map sensor ill get back too you and let you know thanks
Reply With Quote Quick reply to this message
  #4  
Old 01-25-2013, 07:03 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,223
Thanks: 14
Thanked 63 Times in 62 Posts
Feedback Score: 0 reviews
No problem bud! Keep me posted. I bet the map sensor fixes your problem. While your at it you should pull out the IAT2 sensor and clean it also. Its right behind the map sensor. It also gets all gunked up from the egr and ccv.
Reply With Quote Quick reply to this message
  #5  
Old 01-26-2013, 05:08 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: ontario
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
changed the MAP sensor and cleaned the one behind it which was caked..went and tried it and the trucks still not working.....really high boost and it doesnt go anywhere, i cant even drive down the road it just spools out....any ideas?
Reply With Quote Quick reply to this message
  #6  
Old 03-08-2013, 06:55 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,606
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Let me guess your egr is deleted? I've been dealing with this problem myself it only happens when it's cold out. If your egr is deleted the air isn't flowwing thru there enough and let's the tube freeze solid your exhaust will sometimes sound like a cummins and other times 40psi for no reason! The tube has to be relocated or heat wrapped somehow. I bet this is your problem type in 6.4 ebp tube frozen. In google lots of threads on it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:41 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors