New HPFP and truck dies when I accelerate it, makes weird noise. - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-14-2012, 07:58 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
New HPFP and truck dies when I accelerate it, makes weird noise.

Replaced the HPFP today with radiator and oil cooler, when I start the truck and put in drive if I accelerate it dies, once it runs for a couple of minutes I can drive it around no problem but it makes a noise like when a tv channel is offline when the turbo boost is over 10#. Is throwing code p0087 What the hell did I do wrong? Any ideas guys?

Last edited by Steinbrenner; 12-14-2012 at 08:35 PM.
Steinbrenner is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-16-2012, 10:55 AM
Powerstroke.org Fanatic
 
Join Date: Nov 2012
Posts: 145
Thanks: 8
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
P0087 - low rail pressure

Might be air in your fuel system now? Did you cycle the key on/off 4-5 times to prime the fuel system? I just changed my filters out yesterday and I cycled the key on for about 30 seconds each time until the tank stopped burbling.

Also double check to make sure the filter is fully seated, maybe it's sucking air past it.

Last edited by Alaskan_awd; 12-16-2012 at 11:00 AM.
Alaskan_awd is offline  
post #3 of 3 Old 12-17-2012, 06:55 PM
Member
 
Join Date: Feb 2008
Posts: 88
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Steinbrenner View Post
Replaced the HPFP today with radiator and oil cooler, when I start the truck and put in drive if I accelerate it dies, once it runs for a couple of minutes I can drive it around no problem but it makes a noise like when a tv channel is offline when the turbo boost is over 10#. Is throwing code p0087 What the hell did I do wrong? Any ideas guys?
---------------------------------------------------------------------------------------------------
Could be fuel leak in the HPFP fuel lines.

Did you replace the lines and gaskets per replacement procedures. Did you reset ECM fuel parameters per Ford service manual.

What code did you have before replacement? Was it P0088 only?

2008 F350 6.4 4x4 DRW CC 4:10 King Ranch Job3
Max2006 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome