Truck won't start after new HPFP - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-20-2012, 11:52 AM
Member
 

Join Date: Jan 2012
Location: Tyler
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck won't start after new HPFP

Have an 08 f250. Truck shut off going down the road. Got towed to my place and it had a p0088 code. I knew these trucks were bad about hpfp. So I replaced pump and now still won't crank. What should my steps be?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-20-2012, 04:05 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,281
Thanks: 22
Thanked 78 Times in 69 Posts
Feedback Score: 4 reviews
You need to bleed the high pressure fuel system. There is a special tool to allow the air to pass thru and out the inlet side of the fuel cooler.

Did you replace the pump cover gasket/harness also?
Reply With Quote Quick reply to this message
  #3  
Old 11-20-2012, 04:36 PM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where can I get that tool? And I have been draining out of the valve on the fuel cooler. And yes I did replace the cover gasket/harness
Reply With Quote Quick reply to this message
  #4  
Old 11-20-2012, 04:48 PM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Also why would it just die while I was driving it? And not restart?
Reply With Quote Quick reply to this message
  #5  
Old 11-26-2012, 08:10 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2012
Posts: 108
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you try an start it after the code was cleared? I had a battery that was shorting out, causing a surge. Shut my truck off while driving to save all the modules from frying. If i deleted the code it would fire up again. Had nothing to do with HPFP though.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:50 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors