Tail Light Fuse Keeps Blowing - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-18-2012, 08:14 AM Thread Starter
Compression Ignition Addict
upd103's Avatar
Join Date: Apr 2012
Location: Huntsville, TX
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to upd103 Send a message via Skype™ to upd103
Tail Light Fuse Keeps Blowing

OK. About a month ago, the tail light fuse on the truck blew when my wife pulled the horse trailer.

She replaced the fuse, and pulled the trailer back without any problems and without blowing a fuse. Everything was good.

She pulled the trailer again yesterday, and once again, blew the fuse. This time though, the new fuses blow as soon as she replaces them. Literally as soon as it makes contact.

What do y'all think is wrong? Do you think one of the relays under the hood took a crap and is causing the short? I don't think it's the trailer because it pulled fine on the way back from Dallas last month. And now, the fuse is blowing without the trailer even being connected.

The relay is the only thing I can think of. What do y'all think?

BTW, I'm in Afghanistan, and the wife is in TX, so that's why I haven't personally gotten to play with it.

upd103 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome