Limp mode after hard acceleration - Ford Powerstroke Diesel Forum

6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-30-2012, 08:03 PM Thread Starter
Powerstroke.org Rookie
 
jkypuros's Avatar
 
Join Date: Apr 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Limp mode after hard acceleration

After accelerating hard entering ramp onto interstate the truck suddenly lost power. After a couple of minutes the check engine light came on. A few minutes after that the truck went into limp mode displaying the wrench symbol. Hoping it's just a bad sensor. Taking to the regular service department at dealership that has always worked on the truck later this week.
jkypuros is offline  
post #2 of 6 Old 08-02-2012, 04:35 AM Thread Starter
Powerstroke.org Rookie
 
jkypuros's Avatar
 
Join Date: Apr 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It turned out to be a failed dpf sensor and failed EGR valve. The service department quote for replacing these was $1200. Instead of replacing these I'm going to install a tuner and dpf delete. Since the tuner turns the EGR valves off will this resolve the problem of the failed EGR valve? If not, do I need to install a complete EGR delete and replace the EGR valve with an intake elbow?
jkypuros is offline  
post #3 of 6 Old 08-02-2012, 05:52 AM
Compression Ignition Addict
 
superduty6.4's Avatar
 
Join Date: Mar 2012
Location: Alberta
Posts: 1,375
Thanks: 3
Thanked 15 Times in 15 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by jkypuros View Post
It turned out to be a failed dpf sensor and failed EGR valve. The service department quote for replacing these was $1200. Instead of replacing these I'm going to install a tuner and dpf delete. Since the tuner turns the EGR valves off will this resolve the problem of the failed EGR valve? If not, do I need to install a complete EGR delete and replace the EGR valve with an intake elbow?
The tuner will just disable the egr system. Without removing the coolers and blocking the ports there is still a possibility of a cooler failing which makes it possible for coolant to enter the cylinders. However the 6.4 litre egr cooler system isn't as troublesome as the 6.0 was but people just do it on the 6.4 for peace of mind.

08 F350 JOB 1
H&S MINI MAXX HD300 W/S1M
SINISTER EGR/COOLER DELETE
6000K BEAMERS HID HEAD & FOGLIGHTS
KMC XD WHEELS W/NITTO TRAIL GRAPPLERS
2.5" LEVELING KIT
DIESELSITE COOLANT FILTER
ROTELLA EC-1 RATED COOLANT
5" DP BACK FLO-PRO EXHAUST
FLO-PRO CAC PIPE & INTAKE ELBOW
CCV MOD
AIR LIFT 5000LB AIR BAGS W/ONBOARD COMPRESSOR
AFE CAI
PMF TRACTION BARS
superduty6.4 is offline  
post #4 of 6 Old 08-08-2012, 09:39 AM Thread Starter
Powerstroke.org Rookie
 
jkypuros's Avatar
 
Join Date: Apr 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I went ahead and installed a mini maxx and deleted the DPF and CAT. The wrench light and engine light are gone and the truck is no longer in limp mode. The truck runs great. The cruise control was not working though so I disconnected the batteries and is working fine now. Thanks to being a member of this forum and reading others posts regularly, I knew exactly what to do when the shop told me the EGR valve was stuck and a sensor in the DPF had failed. Thanks guys!
jkypuros is offline  
post #5 of 6 Old 08-08-2012, 07:43 PM
Compression Ignition Addict
 
countryraised's Avatar
 
Join Date: Apr 2009
Location: northeast Iowa
Posts: 854
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
occasionally right after reprogramming my cruise does not work either. However simple shutting it off and restarting always has fixed it. without pulling battery cables.

Vince
John Deere product developement
FOR SALE '99F350 2008 F350 mini maxx'd

countryraised is offline  
post #6 of 6 Old 08-21-2012, 08:01 PM
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Angry 6.4L problems 2008 ford f350

Hey guys I'm a new user here not sure if this post is going to be where it's supposed to. Got a mini max , air intake and straight pipe exhaust done on my 2008 ford f-350 , driving back home one day first the air pressure sensor came on for tires then the traction control light came on the dash , heard weird sound coming from engine I pulled over and the intake rubber seal came off turbo. Put clamps and intake back on tried to start the truck wouldn't start. Had a friend come with OBD computer and reset the codes the truck ran fine for ten minutes and then same thing happened. Truck seems to rpm high before changing gears , scared to go to ford with the chip even though it's warrantied for four years. Any advice ? Traction control light (truck switching picture) is on and traction control button is set to off in 2wd I can't turn it back on as well as cruise control not working. Any advice would be awesome thank you, and I apologize again if I don't lost this in the right thread. Oh and truck wont start , have to bypass with the brown wire with yellow stripe beside passenger side battery to turn it on, idles fine though.
Richarddst is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome