6.4 Fuel pump/White smoke - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-24-2012, 02:17 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
6.4 Fuel pump/White smoke

I have an 08 6.4 with a SCT Livewire and DPF delete. I have had the SCT programmed on the Extreme setting for 2 years due to the high MPG with no problems other than the standard updates. The truck started shutting down into protective mode (no power, engine choking out but still running)and throwing the P0088 code. If you turned the key off and restarted everything was fine for a while but gradually got worse and was shutting down every few miles.

I reprogrammed the computer to the towing setting. This stopped the shutting down but the truck would choke out of you gave it too much pedal. This worked for a few weeks.

Now all codes are gone but the truck is throwing white smoke out the exhaust. I have the SCT programmed to turn off the ERG.


Any ideas on what this could be? With the P0088 code i origionally thought it would be the HPFP but now im stumped...


Thanks.
Romine2727 is offline  
post #2 of 6 Old 07-24-2012, 04:23 PM
Premium Member
 
ryandamo's Avatar
 
Join Date: Jun 2009
Location: Connecticut
Posts: 1,205
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
if its throwing out white smoke, its most likely a cracked egr or headgaskets


2016 F450 6.7L XLT 4x4Dump, bone stock
1994 F250 7.3L XLT 4x4 ZF5 , Centurion, 4" Lift, 6637, Gulf Coast Bypass Filter, Big fuel tanks, dana 60 swap, No longer dually
1997 F350 7.3L XLT 4x4Dump, E4OD, 4 in exhaust, TS 6 position, 3/8 Trans line+external filter
2013 Scag Turf Tiger 61" 1.1L Caterpillar Diesel
1960 John Deere 440 Backhoe 2-53 detroit
ryandamo is offline  
post #3 of 6 Old 07-24-2012, 04:57 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I accidentally ran the truck on factory setting (with the DPF Del) a few years ago and it threw white smoke like it is now. I reprogrammed and it was fine.

I tried that this time but it didn't work.
Romine2727 is offline  
post #4 of 6 Old 07-25-2012, 07:33 PM
Compression Ignition Addict
 
Capt dong's Avatar
 
Join Date: Jul 2011
Location: Houston
Posts: 1,149
Thanks: 8
Thanked 10 Times in 10 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
any temp readings?

08 F250 KR
08 F250 XL
Capt dong is offline  
post #5 of 6 Old 07-26-2012, 04:25 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
164 deg. (after 30 miles running 75)I drove it to work this morning. No white smoke, no P0088 and ran like a champ. Only codes showing up now is P0128 & P1000
Romine2727 is offline  
post #6 of 6 Old 07-30-2012, 05:25 PM
Member
 
Join Date: Jan 2012
Location: sammamish wa
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2010 xlt fx4 6.4

ford replaced the charge air cooler
issyrog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome