Loss of power, need ideas - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-05-2012, 06:35 PM Thread Starter
Powerstroke.org Fanatic
 
PlatinumDiesel's Avatar
 
Join Date: Apr 2012
Location: Lubbock
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loss of power, need ideas

I have an 08 HD f250 6.4.. HS tuner, EGR delete, elite waste gate kit, banks IC, elite IC tubes, flo-pro intake elbow (which is causing a CEL that is pissing me off), and an afe intake. Nothing major. I have about $25k worth of parts to put on sitting in my floor but I'd rather build another truck with them. Lately, I'd been running the HD tunes and it began smoking like hell. I got tired of it so I retuned it to run normal tunes. Now, I'm only building ~25 psi and there is NO massive accel like the tuned 6.4 is known for. It falls flat on its face. Fuel pressure is 24.5k psi max even in HOT. I'm thinking it's the high pressure turbo. Could it be the hpfp? Any input would be nice..


Sent from my Autoguide iPhone app
PlatinumDiesel is offline  
post #2 of 3 Old 07-16-2012, 11:53 PM
Compression Ignition Addict
 
Join Date: Jul 2008
Location: Temple, TX
Posts: 224
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
pull off the fuel cooler and check if the high side turbo is sticking, and do you have the updated oil feed line to the turbo?

2003 F350 7.3L Lariat FX4
05-07 badges
05-07 front conversion
casserly stage 2 165cc injectors
srp1.1 hpop
gtp38r (should've done h2e )
custom 6 position chip
isspro ev2 gauges
6inch lift
4inch Straight Pipe
Mt's 37x13.50 R20
3.73 gears
billet converter
48 gallon fuel tank
08 Front and Rear Axles
plus more.....

soon to come: bts trans.
swalker332 is offline  
post #3 of 3 Old 07-17-2012, 04:48 AM Thread Starter
Powerstroke.org Fanatic
 
PlatinumDiesel's Avatar
 
Join Date: Apr 2012
Location: Lubbock
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sorry, I should have updated this.. I used my Solus Pro and found the exhaust back pressure sensor out of range. The old one was clogged to **** and I stuck a new one on there after cleaning out the line with brake clean. Runs perfect.


Sent from my Autoguide iPhone app
PlatinumDiesel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome