Bad injectors - Ford Powerstroke Diesel Forum

6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-25-2012, 08:10 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Bad injectors

I replaced new fuel system i had rust in it also my tank and had a flush done but now my injectors are going out only 2 and always the same ones, dealership hasent gave me an answer whats wrong with it only 32,000 miles
6.4jerry is offline  
post #2 of 2 Old 06-26-2012, 12:04 AM
Compression Ignition Addict
 
Capt dong's Avatar
 
Join Date: Jul 2011
Location: Houston
Posts: 1,148
Thanks: 8
Thanked 10 Times in 10 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
id like to know also. just replaced fuel filters. last set was in there for less than 10k miles. drained once a month. lots of brown orange-ish specs everywhere. i figure dirty fuel has some play in it. i fill up at "clean" or busy stations but that probably doesnt mean squat. at least there wasnt much water if at all during the drainings.

08 F250 KR
08 F250 XL
Capt dong is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome