2008 dually loose power at 70 MPH - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-13-2012, 09:04 AM Thread Starter
Powerstroke.org Fanatic
Remi19's Avatar
Join Date: Jan 2010
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
2008 dually loose power at 70 MPH

I have a 2008 Ford 6.4 diesel dually When I pull a trailer and get it up to around 70. The truck will loose all power and shut down to around 55 or 60 and will not go any faster. then a wrench will show up on the screen. If I pull over shut the engine off and turn it back on. It will run fine as long a I do not get back up to 70 again ?
Remi19 is offline  
Sponsored Links
post #2 of 2 Old 02-13-2012, 01:58 PM
Powerstroke.org Fanatic
6.4ford's Avatar
Join Date: Dec 2011
Posts: 134
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If u don't have the latest flash from ford I'd advise u to go get it and see if that helps

Sent from my Autoguide iPhone app
6.4ford is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome