Erratic Boost and Turbo Flutter - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-06-2012, 06:05 AM Thread Starter Rookie
Join Date: Feb 2012
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Erratic Boost and Turbo Flutter

I have a 2008 6.4 with 20500 miles. A few days ago I noticed a very loud turbo flutter when I let off the gas, say to make a turn. Today I noticed the same flutter, but when I let off the gas, the boost doesn't bleed off. It stays at or a little above 10psi, then after a few seconds, it bleeds off. This is accompanied by a loud turbo flutter. While getting on the interstate, I had extremely erratic boost. The gauge was constantly going from 0 to 30 and everywhere in between, like a pendulum. I have noticed that it doesn't drop below 20 psi while driving 60 to 75 mph, but I don't know if this is normal or not. I have had the truck for 7 days, and it is my first diesel truck.

Does anyone have any ideas of what is wrong?
Sparkadaus is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome