USED TRUCKED Problems - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-04-2012, 12:48 PM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Location: South Jersey
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
USED TRUCKED Problems

Ok, So here it goes. Hopefully someone can answer a few things for me. My truck seems to have some electrical problems when i bought it, didn't realize, So, looks like I'm going to be fixing it all. One good thing is that it came with a full DPF deleted SS exhaust, off road tuner, and an Stage 2 intake already in it. So i guess fixing everything thats wrong with it will cost me what all that would have costed me I have a 08' king ranch 6.4 f250.

1. Running lights on mirrors don't light, but blinkers work.

2. Mirrors on both sides can be adjusted out and up, but not down and in.

3. When adjusting the mirrors down, either side, the mirrors don't move but the pedals adjust and go down.

4. Adjustable pedal switch will bring them up, but not down.

5. Back up sensor switch is always on off when in reverse. won't let turn on or off. But switch goes does not go off if i don't put truck in reverse. Soon as i do, the switch goes off.

6. Motor sounds weird on the left side of the motor, only at 2000+ RPMs, thinking maybe EGR?

Now the first 4 problems I believe is through the seat processor underneath the seat. It has a plug which has all of the wires from the mirrors to the pedals to the seat controls go to this processor in one harness. Is it possible that this processor is bad, or going bad? Or is it the harness? I believe the harness had been replaced because all the wires were cut and soldered back together. I checked every wire to make sure all colors matched that were put back together right, all were shrink wrapped, nothing split. The only thing i could think of is that there are 3 yellows in the same harness and maybe they got swapped, but that has nothing to do with pedals or lights, they are mirror returns or something like that. I don't want to buy the processor and find out its not that because no company will accept electronics back and its a 150$ part.

The back up sensor problem has to be a sensor in the bumper Correct? How do you find out which one it is?

I know this is a list of BS but I'd only come here for advice. Very frustrated. Please Please Help! THANKS GUYS in advance.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-04-2012, 01:06 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: Hazzard County
Posts: 254
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My only help would be with the Reverse Question.

Yes, you probably have at least 1 bad sensor. I say this from Experience. I had 2 of them Unplugged and Out, and I had the same symptoms you mentioned. I could Not switch the dash switch Off/On. It was Always in OFF when I selected reverse.

If you are in need of a Sensor, I'd suggest Ebay for your search. I think I paid around $45 for 1 sensor.

Sorry about the other problems, I have no Idea.

Good Luck!
Reply With Quote Quick reply to this message
  #3  
Old 01-04-2012, 05:57 PM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Location: South Jersey
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How do you know which one was bad, I have an idea that one is because it popped off easily and had water in it. idk if the harness is bad too.
Reply With Quote Quick reply to this message
  #4  
Old 01-04-2012, 06:19 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: Hazzard County
Posts: 254
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'd start there. I doubt your harness is going to be an issue, just the sensor.

My situation was a little different. I replaced my rear bumper and broke 2 of them trying to get them apart.

They are fragile, don't manhandle them.
Reply With Quote Quick reply to this message
  #5  
Old 01-05-2012, 11:52 AM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Location: South Jersey
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok, well there are none on there anymore for 45$, of course, my luck. But i presume the chatter noise, not normal diesel chatter, that i hear on the driver side is the egr. Ill be buying the delete this weekend, so we shall see if it goes away.

Any one have anything on the seat control module?
Reply With Quote Quick reply to this message
  #6  
Old 01-09-2012, 04:47 PM
Compression Ignition Addict
 

Join Date: Nov 2010
Location: winnipeg
Posts: 236
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by kruu8887 View Post
How do you know which one was bad, I have an idea that one is because it popped off easily and had water in it. idk if the harness is bad too.
block wheels turn key to on but DO NOT START TRUCK put in reverse go to bumper use a stethoscope and listen to each sensor they will make a criket sound the one that makes no sound will be the one with the failure the ones on each end take alot of sh*t from the wheels the plugs will get water in
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:36 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors