6.4l 08 F250 Strange leaking - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 02-04-2011, 11:32 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
6.4l 08 F250 Strange leaking

I have what is most like oil on one of my radiators, but it seems to be coming from a coolant hose...? This has only occurred since I had my transmission lines replaced.

I wiped off my radiator and the oil appeared again. Also, when using Tow/Haul and hauling 2-3 ton trailers, it smells like oil on the engine block!

Avondale is offline  
post #2 of 5 Old 02-05-2011, 02:08 PM
Powerstroke.org Fanatic
 
Join Date: Dec 2010
Location: K.C.
Posts: 95
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I would say that your transmissionl ines you had replaced are not done correctly or are not tightned correctly. It is easy to crossthread those lines into the radiator if you are not carefull. I would venture to say it is transmission fluid leakiing out of the lines where they are connected to the radiator. Good luck and let us know what you find out.

Last edited by sportsfreaked; 02-05-2011 at 02:08 PM. Reason: mis spelled
sportsfreaked is offline  
post #3 of 5 Old 02-08-2011, 02:32 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Looked a bit closer at the buildup by swabbing it on a white napkin... looked like soot. Made me think something about an exhaust system would have something to do with it... realized that the giant hose is the turbo cooler... turbo's burn oil...

I rev'd it up and sure nuff, a spurt of air jetted from the rubber joint. Patched it up. Hope all is well. Thanks!
Avondale is offline  
post #4 of 5 Old 02-17-2011, 04:12 AM
Member
 
Join Date: Nov 2007
Location: Niagara Falls, ontario, Canada
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
its residual oil from the turbos. normal for bearing turbos.
Cablifter is offline  
post #5 of 5 Old 02-17-2011, 04:12 AM
Member
 
Join Date: Nov 2007
Location: Niagara Falls, ontario, Canada
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
make sure the staples didnt puncture the hose and start leaking.
Cablifter is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome