After PCM update - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2010, 08:30 PM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
After PCM update

I have an 08 F-250 4X4 6.4....I've had it at the dealer 4 times. Got the radiator and fuel bracket recall...problem is with the PCM reprogram. After the first one, truck was in almost constant regen. Turbo boost fluctuating 20 to 5 back to 20 around 35-40 MPH. Fuel mileage sucked...it never showed ANY kind of message in the DIC. Took it back...they said the MAF sensor had oil on it and reflashed it again. Truck went into regen the next day and has had the same symptoms as before (won't hold turbo boost, high idle, HOT exhaust after shut down, poor MPG) and it STILL does not tell me anything in the DIC about regen....anyone have any ideas? Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-19-2010, 03:20 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Forest Hill, Maryland
Posts: 297
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How do you know it went into regen with no display? The latest flash apparently only allows the cleaning message to pop up for a short time then disappears. Any smoke or power loss?
Reply With Quote Quick reply to this message
  #3  
Old 03-22-2010, 01:55 PM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm "assuming" it's regen....it has all the regen symptoms....turbo won't maintain boost above 20...constantly boosts up the down even when climbing hills with steady accelarator pressure. High idle, popping hot exhaust on shutdown with the "burning" smell that usually accompanies regen. Poor mileage. The truck seems to have way more valve clatter than it used to, like it's running on all motor with no boost. (Does that make sense?) The dealer said the message is supposed to appear when in regen and then tell you when complete with this PCM program, but I've never seen nada....it's really starting to be irratating. Especially the constant up and down turbo "burps"....if it's not that, then I'll have to have them diagnose it again. Personally, I can't wait until the warranty is up so I can strip all that crap off and reprogram myself. I have heard there's been some first stage turbo issues with these, but I don't think that's it.
Reply With Quote Quick reply to this message
  #4  
Old 03-22-2010, 02:38 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Forest Hill, Maryland
Posts: 297
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm in the same boat. I haven't seen the message since I had the EGR valve replaced and they re-flashed it. I've been looking for the message for 400 miles, not that I'm complaining if it doesn't regen.
Reply With Quote Quick reply to this message
  #5  
Old 03-29-2010, 11:15 AM
Powerstroke Techie

 

Join Date: Oct 2009
Posts: 1,677
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
cycle through the system check if you suspect it is in regeneration. It will tell you in there.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:04 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors