Weird thing happened - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-04-2009, 02:09 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: South of 80
Posts: 295
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Weird thing happened

My truck sat outside today for about 5 hours,while i worked on my sleds in the garage, it's cold out about 25%,when i went out to start the truck to put in the garage,turn the key waiting for the glow plug light to go out, then turned the key, nothing.No clicking just silent, then i realize the radio or the blowers not working, so i shut it of an repeat still same thing, try it again the radio turns on with the blower an it fires wright up, it's never done that before,what do you think it is.

thanks chris
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-07-2009, 02:14 PM
Powerstroke Techie

 

Join Date: Oct 2009
Posts: 1,680
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
It was cold, and didn't like you picking on it

How old are the batteries? Connections clean and tight?
Reply With Quote Quick reply to this message
  #3  
Old 12-07-2009, 02:18 PM
Compression Ignition Addict
 

Join Date: Apr 2008
Location: Chicago, IL
Posts: 457
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thought you didn't have to wait to start on the 6.4?
Reply With Quote Quick reply to this message
  #4  
Old 12-07-2009, 02:19 PM
Member
 

Join Date: Nov 2009
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
when was your truck built i have a job 3 08 that does the same thing its happened alot more than once like a dozen maybe more in the past 6 months though, and temperature doent seem to affect it? Has this ever happened before to you.
Reply With Quote Quick reply to this message
  #5  
Old 12-07-2009, 04:33 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: South of 80
Posts: 295
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Big Angry Hillbilly View Post
It was cold, and didn't like you picking on it

How old are the batteries? Connections clean and tight?
the batteries have the green light connections are tight and i put "cap" on the terminals it cleans them an gives them better conductivity, it's purple in color. my truck is a 08 job 3
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:53 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors