HELP! Truck not building boost past 20psi. - Ford Powerstroke Diesel Forum
6.4L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-28-2009, 09:39 AM
Member
 

Join Date: Mar 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP! Truck not building boost past 20psi.

I was running RCD's track only tune when I raced a Camaro last night and it didn't feel like it was running right. It normally pulls hard all the way past 100 but once I hit 70 it didn't pull hard and it felt like it didn't want to shift. I loaded the street version and it felt fine at first but when I was driving home it wouldn't go past 20lbs of boost. Now it feels like it is not wanting to shift either. I don't know what is wrong but I was thinking the coverter at first but it builds boost fine up to 20psi then it doesn't go past that and it delays before finally shifting. This is also what one of the members on thedieselgarage.com stated as well. The EGT's don't go over 800. The tranny temps were aroun 174 or so, the ECT's were around 194, and the oil was 94-96 on the livewire. If anybody has had any similar issues please help me out. Also it normally bellows out smoke with both tunes but now I don't see any.
Thanks in advance.
Alex
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-29-2009, 11:24 PM
Emergency Services

 

Join Date: Nov 2007
Location: Hawaii
Posts: 626
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you scan for any DTC's?
Reply With Quote Quick reply to this message
  #3  
Old 06-30-2009, 07:21 AM
Emergency Services

 

Join Date: Apr 2008
Location: Beeville, TX
Posts: 1,489
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Me thinks your HPFP is a bit flaky. Scan for codes, you may find a P0087 (fuel rail pressure low). Mine would do exactly what you are talking about, then it got worse to the point that it wouldn't go over 35mph. The shifting is screwed up because the you don't have any power. The boost is screwed up because you don't have the fuel to burn to make the exhaust to make the intake charge.

Tuners have been known to cause a weak HPFP to go out. It would have gone out anyway, but it would have taken longer.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:42 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors