Straight pipe installed, sct livewire ts installed, now problems - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-16-2014, 02:30 PM Thread Starter
Compression Ignition Addict
 
Flaboystrokin's Avatar
 
Join Date: Apr 2013
Location: Clermont, Fl
Posts: 168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Straight pipe installed, sct livewire ts installed, now problems

hey guys, just installed my flo pro 4in downpipe back dpf delete exhaust, and my SCT livewire ts, with rudys tunes they pre loaded on the tuner, i am on level 5. and the turbo boost is not registering on the screen, everything else works, but the turbo boost gauge. my analog gauge works prefectly but the digital on the screen does not.

another concern i have is the engine oil temp, it takes FOREVER for mine to get up to temp. my coolant could be @ 180-190 and my engine oil temp is @ 88-95. should i be worried about this?

2009 F-250 Lariat FX4
-FLO-PRO 4" downpipe back with 6" mbrp tip
-Sinister EGR delete
-S&B intake
-H&S Mini Maxx, MCC tuned
-LED headlights
-20x12 fuel mavericks
-305/50 420's
Flaboystrokin is offline  
post #2 of 5 Old 04-16-2014, 06:26 PM
Compression Ignition Addict
 
superduty6.4's Avatar
 
Join Date: Mar 2012
Location: Alberta
Posts: 1,366
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 3
Thanked 15 Times in 15 Posts
Feedback Score: 0 reviews
Not to sure on your boost guage problem but I do recall someone saying the oil temp is in Fahrenheit.

08 F350 JOB 1
H&S MINI MAXX HD300 W/S1M
SINISTER EGR/COOLER DELETE
6000K BEAMERS HID HEAD & FOGLIGHTS
KMC XD WHEELS W/NITTO TRAIL GRAPPLERS
2.5" LEVELING KIT
DIESELSITE COOLANT FILTER
ROTELLA EC-1 RATED COOLANT
5" DP BACK FLO-PRO EXHAUST
FLO-PRO CAC PIPE & INTAKE ELBOW
CCV MOD
AIR LIFT 5000LB AIR BAGS W/ONBOARD COMPRESSOR
AFE CAI
PMF TRACTION BARS
superduty6.4 is offline  
post #3 of 5 Old 04-16-2014, 06:29 PM
Compression Ignition Addict
 
superduty6.4's Avatar
 
Join Date: Mar 2012
Location: Alberta
Posts: 1,366
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 3
Thanked 15 Times in 15 Posts
Feedback Score: 0 reviews
Sorry I meant EOT in Celsius

08 F350 JOB 1
H&S MINI MAXX HD300 W/S1M
SINISTER EGR/COOLER DELETE
6000K BEAMERS HID HEAD & FOGLIGHTS
KMC XD WHEELS W/NITTO TRAIL GRAPPLERS
2.5" LEVELING KIT
DIESELSITE COOLANT FILTER
ROTELLA EC-1 RATED COOLANT
5" DP BACK FLO-PRO EXHAUST
FLO-PRO CAC PIPE & INTAKE ELBOW
CCV MOD
AIR LIFT 5000LB AIR BAGS W/ONBOARD COMPRESSOR
AFE CAI
PMF TRACTION BARS
superduty6.4 is offline  
post #4 of 5 Old 04-16-2014, 07:26 PM
Compression Ignition Addict
 
WoodBoy's Avatar
 
Join Date: Sep 2010
Posts: 1,706
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
This is something you should call Rudy's right back for.. I know on the livewire the coolant is in Fahrenheit and oil in Celsius but I figured on the TS they would have fixed that?

2010 CC/SB FX4 Lariat.. Tuned By Eric@IDP and Matt@Gearhead

Thinking about getting rid of the stock 6.7 turbo?
Check this out... and research before buying



http://www.powerstroke.org/forum/6-7...ustration.html

http://www.powerstroke.org/forum/6-7...round-2-a.html
WoodBoy is offline  
post #5 of 5 Old 04-17-2014, 03:07 AM Thread Starter
Compression Ignition Addict
 
Flaboystrokin's Avatar
 
Join Date: Apr 2013
Location: Clermont, Fl
Posts: 168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Yes it was set to Celsius. I changed the value to Fahrenheit. Lol simple thing I overlooked when setting the tuner up. Thanks guys. As for the turbo boost not working, im gonna call sct and ask them today what the deal is with that.

2009 F-250 Lariat FX4
-FLO-PRO 4" downpipe back with 6" mbrp tip
-Sinister EGR delete
-S&B intake
-H&S Mini Maxx, MCC tuned
-LED headlights
-20x12 fuel mavericks
-305/50 420's
Flaboystrokin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome