Sct tuner on my 6.4 pulls extremely hard when stopped - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-03-2014, 11:34 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sct tuner on my 6.4 pulls extremely hard when stopped

I'm running an sct tuner on my 6.4 with a full egr delete, turbo back exhaust, and intake
Right when I put my truck into drive, the thing wants to just take off and go. I just replaced my rotors and pads, and still no difference.
This is super annoying when I'm sitting at a light and I have to put my foot down on the brake so I don't keep creeping forwards.
The truck doesn't idle unusually high or anything, and it's done this on every tune that I've tried also
Any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-04-2014, 04:30 AM
Compression Ignition Addict
 

Join Date: Jul 2010
Posts: 643
Thanks: 4
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Do you have gauges? If so, are you building any boost when at a stop? Even 2psi will cause it.
Reply With Quote Quick reply to this message
  #3  
Old 04-04-2014, 07:01 AM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ya just the oem boost gauge. It shows that it is building a little bit of boost
Reply With Quote Quick reply to this message
  #4  
Old 04-04-2014, 08:39 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: Groveport, Ohio
Posts: 511
Thanks: 5
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Sounds like the tune needs adjusted. When I had custom tunes I was getting a shift flare on my street tune, had them correct it and no issues. I probably should have tried my hot street to have them adjust that as well, but pansied out. The Tow tune was 100% fine from day one though.

I'd look at that part of it first, but sounds like it has to do with the tune pushing for PSI all the time.
Reply With Quote Quick reply to this message
  #5  
Old 04-04-2014, 10:12 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 570
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have you put in an aftermarket torque converter?
Reply With Quote Quick reply to this message
  #6  
Old 04-04-2014, 10:21 AM
Compression Ignition Addict
 

Join Date: Jul 2010
Posts: 643
Thanks: 4
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by garyn77 View Post
Ya just the oem boost gauge. It shows that it is building a little bit of boost
OK, you should not be building boost when at a stop....period. I would try another tune first and see if it continues. If not, you need the tunes cleaned up a bit, or just a different tune. Remember the 6.4 is an animal in many ways.....no two trucks are the same. If it turns out to not be your tune, you need to check for codes.....I would look for anything related to turbos, boost sensors, EBP sensor.....
Reply With Quote Quick reply to this message
  #7  
Old 04-04-2014, 10:27 AM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ya I will have to look and see what I can do about the tune I guess

And there are no codes showing. The truck has done it since day one of installing the tuner
Reply With Quote Quick reply to this message
  #8  
Old 04-04-2014, 10:41 AM
Compression Ignition Addict
 

Join Date: Jul 2010
Posts: 643
Thanks: 4
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by garyn77 View Post
Ya I will have to look and see what I can do about the tune I guess

And there are no codes showing. The truck has done it since day one of installing the tuner
Have you tried just reloading the tune? If not, give it a try. These trucks do some strange things.
Reply With Quote Quick reply to this message
  #9  
Old 04-04-2014, 12:12 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ya I have tried that. Also updated my tuner the other week too

Called sct this afternoon and they are looking over the tune files off my programmer. I will let you guys know what they have to say when I get a call back
Reply With Quote Quick reply to this message
  #10  
Old 04-04-2014, 03:19 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I talked to sct. They couldn't find anything wrong . They did suggest taking it to the dealership and having my PCM updated, and then retuning my truck
I don't see how this could solve it though. I was under the impression that when I program my truck with my tuner, that it completely wrote over the ford software. Also ford wants $160 just to reflash it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
sct, tuner

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:13 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors