CEL P1633 - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-01-2014, 09:19 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2013
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
CEL P1633

I have a CEL that has been on in my truck, everything seems to run fine, no noticable issue. The code is P1633, keep alive voltage too low. I have no idea where to start, asked at autozone, they had no idea, my mech had no idea and I asked a Ford mech he was even unsure. anyone have this happen to them?

It started after my mini maxx was put in my truck, no sure if that changes anything, the light on my dash drives me crazy though. Thank You for any help
mtfd49 is offline  
post #2 of 3 Old 04-03-2014, 02:25 AM
Premium Member
 
B585Ford's Avatar
 
Join Date: Nov 2011
Location: West By God Virginia
Posts: 1,807
Thanks: 35
Thanked 73 Times in 67 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by mtfd49 View Post
I have a CEL that has been on in my truck, everything seems to run fine, no noticable issue. The code is P1633, keep alive voltage too low. I have no idea where to start, asked at autozone, they had no idea, my mech had no idea and I asked a Ford mech he was even unsure. anyone have this happen to them?

It started after my mini maxx was put in my truck, no sure if that changes anything, the light on my dash drives me crazy though. Thank You for any help
Had you been driving right before you installed the MM? Did you clear the code and see if it would come back?

2008 F350 ZF6 daily driver
No Limits CAI and every air mod, MM w/ GH, DPF/CAT delete 5", Sean's 4" DP, SB DD 3850, Coolant Filter, Bushwacker flares, 2.5" Icon level, SD inserts tailgate/grill, PMF Tbars w/ 5" block, Elite EGR delete, Junior High Power Atmo, ARP studs, A-1000 (Marty's), Fuel Bowl Delete, 15% nozzles, Tial WG
God Bless our military!!!!
Please see this thread:
http://www.powerstroke.org/forum/pow...l#post10310033
B585Ford is offline  
post #3 of 3 Old 04-03-2014, 05:40 PM
Member
 
Join Date: Apr 2013
Posts: 42
Thanks: 4
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I'll share something I looked up on my shop computer:
Tests/Procedures:
1. This code suggests power to the TCM has been interrupted. Since this started with a reprogram, a fuse likely blew during the programming process.

2. Check fuse 37 in the battery junction box under the hood. It is a 10 amp fuse. If it is blown, replace the fuse and retest.

3. If the fuse is not blown, the modules should be programmed again using a factory or equivalent scan tool.

That's what it says to do when the problem occurs following a reflash.

2010 F250 Harley Davidson. H&S Mini Maxx Race, MCC, 5" down pipe back SS straight pipe, S&B intake, Snow Performance water/meth, FASS fuel pump, Sinister EGR delete, elbow & CAC pipe, Sinister filter housing caps, Bak Industries F1 tonneau, 295/65/20 Nitto Trail Grapplers, Detroit Truetrac (in box for now), lots of lights!

Last edited by highup0; 04-03-2014 at 05:46 PM.
highup0 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome