Engine Lag - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2014, 08:30 PM
Member
 

Join Date: Mar 2013
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Engine Lag

I dont really know if engine lag describes what is going on, but it seems that every time i slam the gas pedal to the floor especially in a lower gear, when i let off the truck has no throttle response anymore any suggestions. After about 3 minutes it comes back but i dont understand why it does this. I was told to change the fuel filter, which hasnt been changed in a litle while now, or that the egr is possibly clogged, any truth to this?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-09-2014, 08:46 PM
Premium Member
 

Join Date: Nov 2011
Location: West By God Virginia
Posts: 1,588
Thanks: 25
Thanked 57 Times in 54 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Mmace111 View Post
I dont really know if engine lag describes what is going on, but it seems that every time i slam the gas pedal to the floor especially in a lower gear, when i let off the truck has no throttle response anymore any suggestions. After about 3 minutes it comes back but i dont understand why it does this. I was told to change the fuel filter, which hasnt been changed in a litle while now, or that the egr is possibly clogged, any truth to this?
Do you RPMs go up, but the truck doesn't pick up speed or will the engine just not rev?
Do you have mods? How long have you had the truck and how miles have you put on it before this started? What's the temp where you are at? Any codes? What does the tranny fluid look like?

Last edited by B585Ford; 03-09-2014 at 08:54 PM.
Reply With Quote Quick reply to this message
  #3  
Old 03-10-2014, 07:19 AM
Member
 

Join Date: Mar 2013
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by B585Ford View Post
Do you RPMs go up, but the truck doesn't pick up speed or will the engine just not rev?
Do you have mods? How long have you had the truck and how miles have you put on it before this started? What's the temp where you are at? Any codes? What does the tranny fluid look like?
The RPMs dont go past like 2200, so when it happens i just rollin to a parking lot arund like 10 mph and turn it off wait a while and turn it back on and its good to go but it just through a code and this time a whole bunch of white smoke came out of the exhaust i have put 12,xxx miles on it since ive had it the truck itsef has 78,xxx miles on it. The only engine mod i have is a Afe stage 2 Cai, the average temperature here right now is like 25 degrees
Reply With Quote Quick reply to this message
  #4  
Old 03-10-2014, 11:57 AM
Powerstroke.org Sponsor



 

Join Date: Dec 2008
Location: Georgia
Posts: 8,758
Thanks: 4
Thanked 12 Times in 11 Posts
Feedback Score: 0 reviews
Sounds kind of like limp mode.
Reply With Quote Quick reply to this message
  #5  
Old 03-10-2014, 03:21 PM
Premium Member
 

Join Date: Nov 2011
Location: West By God Virginia
Posts: 1,588
Thanks: 25
Thanked 57 Times in 54 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Mmace111 View Post
The RPMs dont go past like 2200, so when it happens i just rollin to a parking lot arund like 10 mph and turn it off wait a while and turn it back on and its good to go but it just through a code and this time a whole bunch of white smoke came out of the exhaust i have put 12,xxx miles on it since ive had it the truck itsef has 78,xxx miles on it. The only engine mod i have is a Afe stage 2 Cai, the average temperature here right now is like 25 degrees
Can you pull the code?
Reply With Quote Quick reply to this message
  #6  
Old 03-10-2014, 03:37 PM
Member
 

Join Date: Mar 2013
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah i just pulled the code its P1335, the scanner mentioned something about the ignition, or misfire
Reply With Quote Quick reply to this message
  #7  
Old 03-10-2014, 03:42 PM
Member
 

Join Date: Mar 2013
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
P1335 Exhaust Gas Recirculation (EGR) Position Sensor Minimum/Maximum Stop Performance
Reply With Quote Quick reply to this message
  #8  
Old 03-10-2014, 04:34 PM
Premium Member
 

Join Date: Nov 2011
Location: West By God Virginia
Posts: 1,588
Thanks: 25
Thanked 57 Times in 54 Posts
Feedback Score: 0 reviews
Hopefully some others will chime in, but that sounds encouraging....white smoke out the exhaust usually ain't a good thing, but an EGR valve failure can cause it. Also, since it was getting opened when you were giving it hell, maybe it was sticking open a little and causing your reduced power. I would confirm it from others but sounds like it might be time to get that mother tr#cker off there and get a programmer (if you don't have a warranty).
Reply With Quote Quick reply to this message
  #9  
Old 03-10-2014, 04:45 PM
Member
 

Join Date: Mar 2013
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah i got a warranty for another 20k so i suppose ill get it fixed, but tuner is first thing on the agenda this spring thats for sure. Thanks for the help bro
Reply With Quote Quick reply to this message
  #10  
Old 03-10-2014, 05:17 PM
Premium Member
 

Join Date: Nov 2011
Location: West By God Virginia
Posts: 1,588
Thanks: 25
Thanked 57 Times in 54 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Mmace111 View Post
Yeah i got a warranty for another 20k so i suppose ill get it fixed, but tuner is first thing on the agenda this spring thats for sure. Thanks for the help bro
Glad to hear you still have a warranty....makes life my cheaper. Hell, now I would be hoping for a stuck injector, cracked piston, f#cked up block....that way you could have a whole new engine under warranty. One word of warning, if you ever do a programmer and deletes, your life will never be the same...so tread cautiously
Good luck with everything and let us know what it turns out to be.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors