CCV Mod - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-02-2008, 07:30 AM
Project Abused

 

Join Date: Nov 2007
Location: Hampton, VA
Posts: 1,165
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
CCV Mod

$5 and 10 mins.
Purpose: Elimate the Closed Crankcase Vent from adding oil into your intercooler which makes your IC less efficent, and saves your boots from getting covered in oil which could help them in slipping off under high boost and ruptures
Hardware Store:
PVC 90 degree elbow, 5/8th or 3/4" Can't remeber: 0.37 each
3 feet of hose once again 5/8 or 3/4: $4
PVC Plug: .37

-Pulled off the stock hose and put new hose into pvc elbow, put pbc elbow on oil housing.
-Shove and secure plug into the hole in the intake, i left the rubber rommet in there as it made it real nice and snug, snugged it down with some JB Weld as well
-Route hose down around oil housing and down through engine bay near front left tire.
-No CEL

Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-02-2008, 07:31 AM
Project Abused

 

Join Date: Nov 2007
Location: Hampton, VA
Posts: 1,165
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i know its easy to make prettier but this works for me but atleast I spray painted the PVC pipe black!
Reply With Quote Quick reply to this message
  #3  
Old 09-02-2008, 07:31 AM
KVFD
 

Join Date: Nov 2007
Location: Kearney, Nebraska
Posts: 4,061
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to redstroker_2002
I bought the ITP Kit. I little more expensive. but at least i dont have to piece it all together and it comes with descriptive directions and pictures!
Reply With Quote Quick reply to this message
  #4  
Old 09-02-2008, 07:57 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Beaumont TX
Posts: 3,802
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How long have you had it this way.....I am guess from your other intercooler posts...only been like this for a few miles....keep me updated as to if you get any codes...if it dont throw one within a couple hundred miles its probably not going to.
Reply With Quote Quick reply to this message
  #5  
Old 09-02-2008, 06:58 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Posts: 401
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks for the info !
Reply With Quote Quick reply to this message
  #6  
Old 09-03-2008, 11:24 AM
Emergency Services

 

Join Date: Nov 2007
Location: Hawaii
Posts: 626
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Good info! Please keep us posted. I was surprised to see that much oil in tube in your IC install thread.
Reply With Quote Quick reply to this message
  #7  
Old 09-03-2008, 11:35 AM
Powerstroke.org Rookie
 

Join Date: Apr 2008
Location: Corpus Christi, Texas
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by redstroker_2002 View Post
I bought the ITP Kit. I little more expensive. but at least i dont have to piece it all together and it comes with descriptive directions and pictures!

Where can I find and IPT kit?
Reply With Quote Quick reply to this message
  #8  
Old 09-03-2008, 03:00 PM
Project Abused

 

Join Date: Nov 2007
Location: Hampton, VA
Posts: 1,165
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dunno where to find it on their site but i know its more than I paid for home made.
Reply With Quote Quick reply to this message
  #9  
Old 09-03-2008, 03:17 PM
International Threat
 

Join Date: May 2006
Location: Elkton, MD
Posts: 13,087
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 1 reviews
Unless you want to filter it and recirculate it back to your intake then don't worry about buying a kit.

Just vent mine to the atmosphere.
Reply With Quote Quick reply to this message
  #10  
Old 09-05-2008, 07:13 AM
Project Abused

 

Join Date: Nov 2007
Location: Hampton, VA
Posts: 1,165
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Over 300 miles and still no CEL
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:48 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors