Mini Maxx Pyro Reading wacked out - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-30-2013, 07:11 AM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Location: Stockbridge, MI
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mini Maxx Pyro Reading wacked out

Hey guys, Ive got an 08 6.4 with a H&S mini running the 250 tune. Last night I was driving home and I noticed my truck defueling erratically. Then noticed my pyro was reading out about 1500-1700 degrees, so I immediately pulled over. At idle it was reading about 900-1000. I made it back to the house, and while doing so I noticed then when you got into the throttle a bit, the pyro would quickly read out normal temps while my foot was in it (500-700), but then went right back to 1500 or so when i let out of it. The truck runs perfectly normal, and my coolant temp never left 190. To me it sounds like my EGT sensor took a dump, but at the same time im nervous as all hell to drive it like that. Has anyone heard of anything like this happening? Any insight would be great,

Thanks! sorry about the long post...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-30-2013, 07:32 AM
Compression Ignition Addict
 

Join Date: Sep 2011
Posts: 3,021
Thanks: 1
Thanked 33 Times in 30 Posts
Feedback Score: 0 reviews
the temperature sensor is probably starting to short out
Reply With Quote Quick reply to this message
  #3  
Old 12-01-2013, 08:25 PM
Premium Member
 

Join Date: Nov 2011
Location: West By God Virginia
Posts: 1,429
Thanks: 15
Thanked 46 Times in 43 Posts
Feedback Score: 0 reviews
I agree with Drunk On Diesel unless when you getting those high readings was it smoking (black) real bad. If you truley had EGTs that high, you would have to be dumping a lot of fuel and since you weren't accelerating, I would say it is very unlikely those EGTs were correct.
Reply With Quote Quick reply to this message
  #4  
Old 12-02-2013, 06:50 AM
Compression Ignition Addict
 

Join Date: Jul 2010
Location: Cincinnati
Posts: 4,182
Thanks: 6
Thanked 36 Times in 35 Posts
Feedback Score: 13 reviews
Yup you need a new egt probe most likely. Mine was doing weird stuff not long ago and now it seems to be working again.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors