Coolant Filter results - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-13-2013, 05:06 PM
Compression Ignition Addict

 

Join Date: May 2012
Location: Broward County
Posts: 641
Thanks: 5
Thanked 4 Times in 3 Posts
Feedback Score: 1 reviews
Coolant Filter results

Added a coolant filter about 5k miles ago. Pulled off the first filter and changed it out. If you're wondering whether it works, I'll let you be the judge. You can see the bits of sand and dirt floating in the top of the filter. Some brown crap came out in the sink when I poured out the coolant, I'm guessing it's rust or something. You can see the sand/dirt piled up right in front of the drain.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-13-2013, 06:37 PM
Compression Ignition Addict
 

Join Date: Nov 2010
Location: Fort St John, BC
Posts: 1,651
Thanks: 1
Thanked 7 Times in 6 Posts
Feedback Score: 0 reviews
This is the first filter with 5k on it? Thats nasty **** in there man! I changed my first one after about 1000 km's but saw nothing. Ill leave this one on for a while (until I R+R rad and coolant swap)
Reply With Quote Quick reply to this message
  #3  
Old 09-13-2013, 06:53 PM
RollinEarly05...now


 

Join Date: May 2008
Location: Klamath Falls
Posts: 3,319
Thanks: 27
Thanked 23 Times in 22 Posts
Feedback Score: 10 reviews
Amazing how nasty the coolant systems can get, even on newer vehicles.
Reply With Quote Quick reply to this message
  #4  
Old 09-16-2013, 06:26 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,215
Thanks: 14
Thanked 62 Times in 61 Posts
Feedback Score: 0 reviews
Did you flush before adding the filter?
Reply With Quote Quick reply to this message
  #5  
Old 09-16-2013, 08:49 AM
Compression Ignition Addict

 

Join Date: May 2012
Location: Broward County
Posts: 641
Thanks: 5
Thanked 4 Times in 3 Posts
Feedback Score: 1 reviews
Filter

Quote:
Originally Posted by 04hdfatboy View Post
Did you flush before adding the filter?
No, using filter to remove debris first then plan on flushing.
Reply With Quote Quick reply to this message
  #6  
Old 09-16-2013, 08:50 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,215
Thanks: 14
Thanked 62 Times in 61 Posts
Feedback Score: 0 reviews
That's a good idea. That's what I did also and it seemed to work well
Reply With Quote Quick reply to this message
  #7  
Old 09-16-2013, 11:42 AM
Compression Ignition Addict
 

Join Date: Nov 2010
Location: Fort St John, BC
Posts: 1,651
Thanks: 1
Thanked 7 Times in 6 Posts
Feedback Score: 0 reviews
Same here, Im curious if mine will look like yours Tony..
Reply With Quote Quick reply to this message
  #8  
Old 09-16-2013, 11:55 PM
Compression Ignition Addict

 

Join Date: May 2012
Location: Broward County
Posts: 641
Thanks: 5
Thanked 4 Times in 3 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by Clayton1985 View Post
Same here, Im curious if mine will look like yours Tony..
For your sake, I hope not.
Reply With Quote Quick reply to this message
  #9  
Old 09-17-2013, 09:50 AM
Premium Member
 

Join Date: Jun 2013
Posts: 403
Thanks: 44
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
So you are saying the filter was almost plugged up with dirt and crap?
Or was trash/dirt floating in the first picture.

Sorry eyes not too good.
Reply With Quote Quick reply to this message
  #10  
Old 09-17-2013, 10:52 AM
Compression Ignition Addict

 

Join Date: May 2012
Location: Broward County
Posts: 641
Thanks: 5
Thanked 4 Times in 3 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by GSchretter View Post
So you are saying the filter was almost plugged up with dirt and crap?
Or was trash/dirt floating in the first picture.

Sorry eyes not too good.
Wasn't plugged up, just had a lot of junk come out when I turned it upside down. Filter definitely works!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:37 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors