Heat question - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-08-2013, 05:45 AM Thread Starter
Member
 
Join Date: Mar 2011
Posts: 62
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Heat question

Hi guys. I posted few times about my truck, seems I got oil cooler going bad. The temps about 20 degrees off. I plan to get fix in next month. Anyways my heat started acting crazy While back and I really just hadn't worried much cuz it is summer. Anyway like you get in in morn no heat, drive for while it starts working, then seems like it stops working again then starts back. Usually after that it works fine but again it's summer and only reason I use is for dew in mornings. So this morn I pay little more attention and it seems soon as coolant and oil temps hit around 190 the heat starts working, then if you stop let idle it quits again until you take off. I'm starting to wonder if it could be thermostat problem? I mean could it be stuck open or not opening ( closing ) soon enough? Thks for any help guys, I don't know alot about the thermostat on these diesels..
Bubba8 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-08-2013, 05:54 AM
Compression Ignition Addict
 
kinnisoj's Avatar
 
Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 6,085
Thanks: 136
Thanked 197 Times in 192 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Does the 6.4 have the same platic pressed on water pump issues that the 6.0 has?

BPD OIL COOLER W/COLD WEATHER PACK & BPD oil bypass amsiol filter
BPD WATER PUMP, RADIATOR+ EGR.ARP STUDS
,edge turbo timer
5" TB DIAMOND EYE EXH
ATLAS 40
TITLE IN HAND...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by kinnisoj; 09-08-2013 at 05:56 AM. Reason: wrong
kinnisoj is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome