truck wants to take off on me - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 12-31-2012, 07:26 AM Thread Starter Rookie
Join Date: Nov 2012
Location: pittsburgh
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
truck wants to take off on me

I just got my truck back from Ford. It went with codes from the #2 injector. The codes popped up from driving up a twisty hill, so I didnt get on it too much, and the truck let out a huge roar and I let off the accelerator and the truck kept going. Pretty scarry! It stopped accelerating then I went to accelerate then it died.
When this was going on I looked in my mirror and saw a huge amount of smoke dumping out.
I've been running the 275LL tune.
So Ford found a cracked piston, bad #2 injector, crcked small block, and a lot of excess oil throughout. They also changed the rocker arms. I also had a full EGR delete with all the pipes and waste gate; and head studs put in while in the shop.
So I was told to put 1000 easy miles on it before I tow or anything. The first few day I ran the 275LL tune since thats all I had for the EGR delete And everything seemed to run fine. Ive been unsure since Ive been runing it light on the peddle.

After about 300 miles in less thatn a week it started to get that loud air intake roar and it tried to take off on me again. I updated my tunes to the EGR deletes and am now runing the lowest tune (40LL).
I was driving up an on ramp to the interstate, it a had a little grade to it, so i had to give it a little more to get up to speed. NOT MUCH and Im in a low tune. And there went a lot of smoke out the pipe and it was driving it self on to the intersate. I was able to resume control.
The past few days Ive been able to control this by listening out for the intake roar and just babying the accelerator to get to highway speeds. It takes me like 45 maybe a minuet to get to 60-65mpg to keep that roar down an hope to not have it take off on me.
Also every time I start it I get a different personalit it seems like...It is always quiet and smooth sounding frome the out side but the differances are some times it will blow more white smoke than i think it should for a longer time after first starting and other times not. AND some times there is a rough idle....not sounding but you can feel it slightly while sitting behind the wheel.

Can anybody help out? Is there anything I can have the tunner monitor while driving? My Ford guy is out for another week.
A little long winded story there, but thanks for reading!
tomichn is offline  
Sponsored Links
post #2 of 2 Old 12-31-2012, 12:00 PM
Compression Ignition Addict

08stroker250's Avatar
Join Date: Dec 2008
Location: Georgia
Posts: 8,819
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 16 Times in 15 Posts
Feedback Score: 0 reviews
I responded to your thread in our tech support forum.

Sounds like more injector troubles to me.

Jeff Dodd

2012 Ford F-250 Lariat CC/SB

Mods - Spartan tuned via laptop, 4" AFE stainless exhaust system, 2.5" PMF BMC leveling spacers, 3" PMF lift blocks, Fox Racing 2.0 shocks, Recon smoked mirror & cab lights
08stroker250 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome