Another Rad Hose Leak :rant: - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-13-2012, 10:37 AM
Member
 

Join Date: Jan 2011
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Another Rad Hose Leak :rant:

Searched around and found some back and forth threads about the issue...

I've got an 08 with 76,000 on it. Just took it in to Ford because there are new spots on the driveway. I checked it out first and saw there was some coolant dripping down off the hose along with some oil around the pan. So between the two warranties I have on the truck I figured it was a no brainer to have it taken care of. Well four hours later I get a call saying the upper hose was leaking not the clamp and that it is not covered.

Now the service writer really started to irritate me by talking to me like I was stupid when I started questioning him. I brought to his attention that they had my truck to replace the EGR one year ago this month with about 63,000 miles on it and they also had it just under four months ago at 72,000 miles. That time they replaced the belt tensioner and noticed the radiator leaking so they replaced that as well, all under warranty. Now I simply asked the service writer if the hose could have been damaged during one of those processes and he just kept telling me that it would have leaked right away and they would have taken care of it and blah blah blah.

I have no idea when it started leaking because my truck parks on top of spots from another vehicle. It was someone else that brought it to my attention after I had pulled out and left. When I saw the leak from under the truck... there were only a few drops. Nothing gushing out. And the level in the bottle was about two inches below the fill line. So in my mind.... It could have been leaking since they had it last. But I need the truck so I told them to just fix the **** thing. He told me $250 to fix the hose and he won't have it in until tomorrow.

I guess I am mostly frustrated because I took it in last time just to have the front hubs replaced. The same service writer called me back about four different times to tell me something else was covered under warranty and could be replaced. Now it is something as simple as a hose and they can't find a way to cover it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-13-2012, 11:52 AM
Member
 

Join Date: Jan 2011
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just realized I posted in the wrong section. Anyone care to move me? Thanks!

...what a noob
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:58 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors