changed out my coolant filter - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-22-2012, 12:03 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Houston
Posts: 1,102
Thanks: 6
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
changed out my coolant filter

put about 3k miles on it. i assume the filter element is white or a yellow. correct me if im wrong. if so then then the coolant was pretty dirty. little bits of sand in every pleat. i thought there would be more material caught since my degas bottle looked so bad.

next on the mods withh be an egr delete then a proper coolant flush.



Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-22-2012, 12:42 PM
Compression Ignition Addict
 

Join Date: May 2009
Posts: 270
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
that is nasty lookin.....the plumbing to your degas bottle....does it look that way because of the coolant filter??....cant put my finger on it,but my setup without filter does not look like that....is the venturi T in there somewhere?
Reply With Quote Quick reply to this message
  #3  
Old 06-22-2012, 12:49 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Houston
Posts: 1,102
Thanks: 6
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
i think the buildup started around the time i put in the stant cap. it actually holds pressure. there was buildup prior but wasnt as bad.

that pic of the degas bottle is prior to installing the venturi tee. yeah its pretty scummy but happy there are no tarballs/oil in the coolant.

the coolant filter lines tap into lines that are on the passenger side of engine so its not around the degas bottle.

another older pic...

Reply With Quote Quick reply to this message
  #4  
Old 06-25-2012, 06:32 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,096
Thanks: 13
Thanked 49 Times in 48 Posts
Feedback Score: 0 reviews
Ya your degas bottle looks pretty nasty. Its probably better you put a coolant filter on first. Hopefully you can catch most of that crap before a coolant flush so you dont clog your oil cooler
Reply With Quote Quick reply to this message
  #5  
Old 06-25-2012, 08:47 AM
Viking Heavy Diesel

 

Join Date: Nov 2007
Location: 34'.6264 -98.4192
Posts: 20,704
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Yup that looks nasty
Reply With Quote Quick reply to this message
  #6  
Old 06-25-2012, 09:16 AM
Compression Ignition Addict
 

Join Date: Sep 2009
Posts: 936
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
"Around the time I put in the stant cap. it actually holds pressure."

you saying the stant camp isn't good? i read on here to update to a stant cap because the spring is bigger and better than the Ford updated one...should i go back to a ford cap? hmm....

Quote:
Originally Posted by Capt dong View Post
i think the buildup started around the time i put in the stant cap. it actually holds pressure. there was buildup prior but wasnt as bad.

that pic of the degas bottle is prior to installing the venturi tee. yeah its pretty scummy but happy there are no tarballs/oil in the coolant.

the coolant filter lines tap into lines that are on the passenger side of engine so its not around the degas bottle.

another older pic...

Reply With Quote Quick reply to this message
  #7  
Old 06-25-2012, 04:10 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Youngstown OH
Posts: 714
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What type of coolant did u use? That looks like what the Dexcool crap does after about 50k.
Reply With Quote Quick reply to this message
  #8  
Old 06-25-2012, 11:31 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Houston
Posts: 1,102
Thanks: 6
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by wilsonw2 View Post
"Around the time I put in the stant cap. it actually holds pressure."

you saying the stant camp isn't good? i read on here to update to a stant cap because the spring is bigger and better than the Ford updated one...should i go back to a ford cap? hmm....
im saying that the stant cap holds pressure and therefore the vacuum pulled the coolant sludge into the degas bottle. could be wrong with my theory but like how the stant cap works.
Reply With Quote Quick reply to this message
  #9  
Old 06-25-2012, 11:33 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Houston
Posts: 1,102
Thanks: 6
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Tsgs69400 View Post
What type of coolant did u use? That looks like what the Dexcool crap does after about 50k.
this is the factory ford gold. have 53k miles. gonna flush, restore and restore plus, distlled water and then cat ec1.
Reply With Quote Quick reply to this message
  #10  
Old 06-26-2012, 04:10 AM
Compression Ignition Addict
 

Join Date: Sep 2009
Posts: 936
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Good call on the cat elc. I'm doing the same here shortly.

So u are happy with ur stant cap? I dont think my ford cap was holding pressure properly. I have to take her in her soon because my tensioner pulley is going and I'm gonna get them to pressure test both caps. I will report back.

Thanks for sharing brother.


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:32 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors