High oil temp with spartan 275 tune - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-19-2012, 07:40 AM Thread Starter
Member
 
Join Date: Sep 2011
Location: Norfolk
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
High oil temp with spartan 275 tune

Hey all its been awhile, been busy at work, new hobbies, and women keeping me from foruming it up. Anyhow I recently installed down pipe back exhaust and spartan tuner on my 08 f450. Been running the 275EL tune with no real problems, other than break neck shifts. Yesterday we had warm winter day, around 55 going down the highway at 60 and my oil temp alarm started going off. I took my foot off the pedal instantly and it dropped to normal within a minute and I finished my trip without problems. Maybe a fluke, maybe not, but it has me concerned cause a typical summer day here is around 100+. I know they make better oil coolers for 6.0s but haven't seen much for 6.4s.
it8eazy is offline  
post #2 of 3 Old 02-19-2012, 04:09 PM
Compression Ignition Addict


 
08stroker250's Avatar
 
Join Date: Dec 2008
Location: Georgia
Posts: 8,819
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 16 Times in 15 Posts
Feedback Score: 0 reviews
Could be a bad sensor. It's definitely not the tune.

Jeff Dodd
spartan_jeff12@yahoo.com

2012 Ford F-250 Lariat CC/SB

Mods - Spartan tuned via laptop, 4" AFE stainless exhaust system, 2.5" PMF BMC leveling spacers, 3" PMF lift blocks, Fox Racing 2.0 shocks, Recon smoked mirror & cab lights
08stroker250 is offline  
post #3 of 3 Old 02-19-2012, 07:12 PM
Compression Ignition Addict
 
Cumminspower11's Avatar
 
Join Date: Jul 2007
Location: Winters, Texas...
Posts: 682
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 08stroker250 View Post
Could be a bad sensor. It's definitely not the tune.
Im with Jeff! Def a bad sensor!

2013 F250 Lariat

2008 F350 Lariat -Spartan Phalanx, 4" MBRP, Leveled, Recon stuff...


3D Oil & Gas
"Oil Production at its Finest"
Cumminspower11 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome