Check engine light after AFE stage 2 SI CAI install? - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 05-09-2011, 08:38 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2011
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Check engine light after AFE stage 2 SI CAI install?

Should I be worrid about this? I had the truck serviced at Ford the day before putting the CAI on, they changed oil and filters etc and gave me a report that everything on the truck looked great.

The truck is running just the same as it did before... Very well. The CAI has been on for a few days now with no problems, this morning,started the truck p and the engine light came on.

Is this normal.... Is it because the sensors are noticing a higher air intake mow and just ot set up for that?

What do I need to do?

Thanks
ps searched the forum but couldn't find anything!

BANKS Monster Dual Exhausts, RBP RX1 steps, DX Monster wheels in Flat Black, Nitto Terra tires, Rancho 4" lift, upgraded bulbs - headlights and fogs. Interior / cab bed/ and licence plate bulbs upgraded to 6k pure white. Window tint. Ford soft bed liner, extang revolution tonneau. Alpine dual 7" DVD screens, DVD player in rear of cab, Alpine wb910 DVD nav in dash.
elmo3000 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 05-09-2011, 08:47 AM
Compression Ignition Addict
 
nccatfan's Avatar
 
Join Date: Sep 2007
Location: Burlington, NC
Posts: 1,007
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to nccatfan
First of all, find out what code triggered the eng. light.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-'99 F250 7.3L PSD 4x4 (SCLB, 6-speed)
-'14 F150 4x4 5.0 CCSB
-'83 Ranger 4X4 5.0

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nccatfan is offline  
post #3 of 9 Old 05-09-2011, 08:56 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2011
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
How do I find out the code? Thanks

BANKS Monster Dual Exhausts, RBP RX1 steps, DX Monster wheels in Flat Black, Nitto Terra tires, Rancho 4" lift, upgraded bulbs - headlights and fogs. Interior / cab bed/ and licence plate bulbs upgraded to 6k pure white. Window tint. Ford soft bed liner, extang revolution tonneau. Alpine dual 7" DVD screens, DVD player in rear of cab, Alpine wb910 DVD nav in dash.
elmo3000 is offline  
post #4 of 9 Old 05-09-2011, 09:03 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2011
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Just did the system check and it says check charging system?

UPDATE did the test where you hold the two buttons and turn on ignition. Didn't start the truck, just turned the key to power. The voltage looks good at 12.2 volts without the truck switched on. The check charging system message has gone but still have the engine light on! ??

I thought that the AFE CAI was not meant to throw codes???

BANKS Monster Dual Exhausts, RBP RX1 steps, DX Monster wheels in Flat Black, Nitto Terra tires, Rancho 4" lift, upgraded bulbs - headlights and fogs. Interior / cab bed/ and licence plate bulbs upgraded to 6k pure white. Window tint. Ford soft bed liner, extang revolution tonneau. Alpine dual 7" DVD screens, DVD player in rear of cab, Alpine wb910 DVD nav in dash.

Last edited by elmo3000; 05-09-2011 at 09:29 AM.
elmo3000 is offline  
post #5 of 9 Old 05-09-2011, 11:00 AM
Compression Ignition Addict
 
blackcloud2k's Avatar
 
Join Date: Nov 2009
Location: Fort Collins, CO
Posts: 2,107
Thanks: 2
Thanked 8 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to blackcloud2k Send a message via Yahoo to blackcloud2k
If I had to guess your check engine light is due to the intake. On tuned trucks an aftermarket intake will not throw codes. On a stock truck alot of times it throws a code because of the increased air volume passing by the mass air flow sensor in the intake tube.

2015 F350 Ruby Red Platinum, SRW CCLB, Color matched Ranchhands, rigids.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

SOLD:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
blackcloud2k is offline  
post #6 of 9 Old 05-09-2011, 12:14 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2011
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
As usual Blackcloud.... Always happy to hear your input! It was my sentiments exactly. I'm pretty sure it is related to air mass, seeing that the truck got a clear bill of health from Ford only days earlier and the truck drives just as well as it did before even with the light on.

I'm waiting on my tuner to come in at the moment, I just thought I'd getbthe CAI fitted before the tuner and DPF delete arrives..... One less upgrade to fit on the same day!

I'll run a diagnostics check with the tuner when it arrives and see what the code is that is being thrown. At least that will give me peace of mind.

BANKS Monster Dual Exhausts, RBP RX1 steps, DX Monster wheels in Flat Black, Nitto Terra tires, Rancho 4" lift, upgraded bulbs - headlights and fogs. Interior / cab bed/ and licence plate bulbs upgraded to 6k pure white. Window tint. Ford soft bed liner, extang revolution tonneau. Alpine dual 7" DVD screens, DVD player in rear of cab, Alpine wb910 DVD nav in dash.
elmo3000 is offline  
post #7 of 9 Old 05-09-2011, 01:33 PM
Compression Ignition Addict
 
blackcloud2k's Avatar
 
Join Date: Nov 2009
Location: Fort Collins, CO
Posts: 2,107
Thanks: 2
Thanked 8 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to blackcloud2k Send a message via Yahoo to blackcloud2k
I bet when you get the tuner and scan thats what you will find. Once you clear the code, as long as the truck is tuned, you shouldnt see the code ever again. I could be wrong, but seeing as thats the only change you have made since it got the clean bill of health Ill place my bets.

2015 F350 Ruby Red Platinum, SRW CCLB, Color matched Ranchhands, rigids.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

SOLD:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
blackcloud2k is offline  
post #8 of 9 Old 05-10-2011, 06:10 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2011
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
So, took the truck for a run today, about 150 miles and the light just turned off. I would imagine that the adaptive learning on the truck has adjusted to the mass air flow?

Anyway it's gone!

BANKS Monster Dual Exhausts, RBP RX1 steps, DX Monster wheels in Flat Black, Nitto Terra tires, Rancho 4" lift, upgraded bulbs - headlights and fogs. Interior / cab bed/ and licence plate bulbs upgraded to 6k pure white. Window tint. Ford soft bed liner, extang revolution tonneau. Alpine dual 7" DVD screens, DVD player in rear of cab, Alpine wb910 DVD nav in dash.
elmo3000 is offline  
post #9 of 9 Old 05-13-2011, 07:39 AM
Compression Ignition Addict
 
blackcloud2k's Avatar
 
Join Date: Nov 2009
Location: Fort Collins, CO
Posts: 2,107
Thanks: 2
Thanked 8 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to blackcloud2k Send a message via Yahoo to blackcloud2k
Sometimes it will go away like that. It may come back it may not

2015 F350 Ruby Red Platinum, SRW CCLB, Color matched Ranchhands, rigids.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

SOLD:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
blackcloud2k is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome