Cold air intake issues - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-14-2011, 06:46 PM Thread Starter
Member
 
Join Date: Feb 2011
Location: Colfax Wa
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cold air intake issues

First i bought an 08 f350 6.4 and stock with a new air filter if i really mash on the throttle usualy in cooler weather i get a check filter light and my filterminder is pulled all the way in. so i thought that the stock filter was to restrictive so i got a good deal on a Volant with power core filter and put it on and it does the same thing maby not quite as bad. so last i assumed the filter minder was bad so i changed that to and still the same thing.any answers or soemone having the same problem
JustinIDFarmboy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-17-2011, 05:45 PM
Compression Ignition Addict
 
INJEKTER1's Avatar
 
Join Date: May 2010
Location: ORYGON
Posts: 1,345
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by JustinIDFarmboy View Post
First i bought an 08 f350 6.4 and stock with a new air filter if i really mash on the throttle usualy in cooler weather i get a check filter light and my filterminder is pulled all the way in. so i thought that the stock filter was to restrictive so i got a good deal on a Volant with power core filter and put it on and it does the same thing maby not quite as bad. so last i assumed the filter minder was bad so i changed that to and still the same thing.any answers or soemone having the same problem
put mine to the floor plenty of times, never had a fault light...........make sure the passenger side grill on the fender is not covered up, the in5take is sucking from it...next i would say possible bad switch on the filter minder.... pull the filter-minder out of its grommet in the intake pipe and try it again...
INJEKTER1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome