Mini Maxx Not Reading - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-18-2011, 01:57 PM Thread Starter
Member
 
BlueDemon09's Avatar
 
Join Date: Jul 2009
Location: South Texas
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mini Maxx Not Reading

A couple weeks ago I started up the truck and noticed that the mini maxx was not reading any parameters at all. It would turn on yet once it finished saying "initializing" all parameters/gauges were at 0 and would never changed. I turned the truck off and started it back up and it seemed to work. Now today it is doing the same thing, yet its like the mini maxx freezes and nothing works. I mean it turns on but doesn't read anything and none of the buttons work. I tried turning the truck off, unplugging the OBD II port and plugging it back in, moving the power switch but no dice. Has anyone experienced anything like this? Any ideas of a fix? Thought I'd just check on here first before contacting H&S, which I still will. Thanks

2009 F250 Lariat PowerStroke CCSB
H&S Mini Maxx|Flo Pro 5"|S&B Intake|3.73's|Hot 300 Tune|KEM 345

BlueDemon09 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-18-2011, 03:44 PM
Powerstroke.org Sponsor
 
Join Date: Jul 2009
Location: Diesel Town, U.S.A.
Posts: 185
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You may just need a software update from our website. Please update the tuner, and if that does not solve the issue please feel free to call us anytime on our tech line at 1-888-628-1730.

-H&S
H&S Performance is offline  
post #3 of 6 Old 02-18-2011, 03:46 PM
Powerstroke.org Sponsor
 
Join Date: Jul 2009
Posts: 387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by BlueDemon09 View Post
A couple weeks ago I started up the truck and noticed that the mini maxx was not reading any parameters at all. It would turn on yet once it finished saying "initializing" all parameters/gauges were at 0 and would never changed. I turned the truck off and started it back up and it seemed to work. Now today it is doing the same thing, yet its like the mini maxx freezes and nothing works. I mean it turns on but doesn't read anything and none of the buttons work. I tried turning the truck off, unplugging the OBD II port and plugging it back in, moving the power switch but no dice. Has anyone experienced anything like this? Any ideas of a fix? Thought I'd just check on here first before contacting H&S, which I still will. Thanks
There is an update available online for just such an issue. We have had a few guys with the same situations and think we have nailed down the issue. Let us know if it works for you. Thanks

Mini Maxx Downloads - H&S Performance

Casey beat me to it! Dang him.....
H&S Tech is offline  
post #4 of 6 Old 02-18-2011, 04:26 PM Thread Starter
Member
 
BlueDemon09's Avatar
 
Join Date: Jul 2009
Location: South Texas
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thx for the reply. I'll give that a try.

2009 F250 Lariat PowerStroke CCSB
H&S Mini Maxx|Flo Pro 5"|S&B Intake|3.73's|Hot 300 Tune|KEM 345

BlueDemon09 is offline  
post #5 of 6 Old 02-19-2011, 08:30 AM
Banned
 
Join Date: Apr 2010
Posts: 337
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Should every one download the new 6.4.21
Vettester is offline  
post #6 of 6 Old 02-19-2011, 11:01 AM
Compression Ignition Addict
 
Join Date: Jul 2009
Posts: 238
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by BlueDemon09 View Post
A couple weeks ago I started up the truck and noticed that the mini maxx was not reading any parameters at all. It would turn on yet once it finished saying "initializing" all parameters/gauges were at 0 and would never changed. I turned the truck off and started it back up and it seemed to work. Now today it is doing the same thing, yet its like the mini maxx freezes and nothing works. I mean it turns on but doesn't read anything and none of the buttons work. I tried turning the truck off, unplugging the OBD II port and plugging it back in, moving the power switch but no dice. Has anyone experienced anything like this? Any ideas of a fix? Thought I'd just check on here first before contacting H&S, which I still will. Thanks
I've had the same problem. Mine will either sit on "initializing communication" or I will get no readings at all. It has also read some parameters but not others. One day it did this and I stopped the truck to turn it and the mini off and the truck wouldn't restart. I reloaded the tune and everything seemed to be fine. I guess I'll have to try this update. I was just getting ready to call H&S until I saw this thread. I really hope this works.

2009 F250 Lariat CC/SB SRW
Icon 2.5 Leveling Kit
37" Toyo MT
Line-X
Suthrn is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome