310 W/Spartan TCM Codes P0766 & P2703 - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-13-2009, 05:27 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 570
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
310 W/Spartan TCM Codes P0766 & P2703

Been running the 310 w/Spartan TCM since its public release and has been running and shifting perect. This morning I ran WOT and it had a couple crazy shifts and threw the codes: p0766 Shift Solenoid Performance or Stuck
P2703 Trans Friction Element 5 Apply Time Range/Perf

Any ideas? Spartan?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-13-2009, 09:05 AM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Deerfield Beach FL
Posts: 1,752
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Send a message via AIM to InMotionJosh
Exact same codes and problems as mine threw the other day with the 310. I only ran the 310 for two days so count your blessings that yours lasted this long.

I ordered a full suncoast rebuild kit, billet shaft, and converter today from Aaron. Hope this is the last transmission issues I encounter
Reply With Quote Quick reply to this message
  #3  
Old 11-13-2009, 09:19 AM
Let's Run'em


 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,690
Thanks: 4
Thanked 14 Times in 13 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Quote:
Originally Posted by drservo View Post
Been running the 310 w/Spartan TCM since its public release and has been running and shifting perect. This morning I ran WOT and it had a couple crazy shifts and threw the codes: p0766 Shift Solenoid Performance or Stuck
P2703 Trans Friction Element 5 Apply Time Range/Perf

Any ideas? Spartan?
Do you run your truck hard alot or was this the first time you got on it in a while?
Reply With Quote Quick reply to this message
  #4  
Old 11-13-2009, 09:55 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 570
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hardly every run WOT, usally drive it pretty easy. I cleared the codes and they havent showed back up yet although I haven't driven it far today and have not ran WOT again.
Reply With Quote Quick reply to this message
  #5  
Old 11-13-2009, 09:56 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 570
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by InMotionJosh View Post
Exact same codes and problems as mine threw the other day with the 310. I only ran the 310 for two days so count your blessings that yours lasted this long.

I ordered a full suncoast rebuild kit, billet shaft, and converter today from Aaron. Hope this is the last transmission issues I encounter
Does it feel like anything is going on with the transmission, tore it down yet, or are you just going off the codes?
Reply With Quote Quick reply to this message
  #6  
Old 11-13-2009, 09:56 AM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Deerfield Beach FL
Posts: 1,752
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Send a message via AIM to InMotionJosh
I hardly ever run my truck real hard but the other night some kid in a Cobalt with Nitrous was purging at me so I showed him some smoke and he tried me three more times...he was sorry....

I was sorry too cause thats when I first got some bad response from my tranny...
Reply With Quote Quick reply to this message
  #7  
Old 11-13-2009, 09:59 AM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Deerfield Beach FL
Posts: 1,752
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Send a message via AIM to InMotionJosh
Quote:
Originally Posted by drservo View Post
Does it feel like anything is going on with the transmission, tore it down yet, or are you just going off the codes?
Going off the codes people say the Solenoid is failing and that the clutches are welding themselves together. Before I took the 310 out any time i would try to accelerate hard my tranny would struggle to find a gear and then I would lose 1st gear all together. 1st gear would come back after I shut the truck off but theres definatly something wrong. Its not torn out yet, I loaded the 150 tune and im babying it around town until monday when my parts come in and I can drop her off at the dealer.
Reply With Quote Quick reply to this message
  #8  
Old 11-13-2009, 11:21 AM
Let's Run'em


 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,690
Thanks: 4
Thanked 14 Times in 13 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Quote:
Originally Posted by drservo View Post
Hardly every run WOT, usally drive it pretty easy. I cleared the codes and they havent showed back up yet although I haven't driven it far today and have not ran WOT again.
I would re-load the tune and hammer down on it, remember this truck learns your driving style and every now and then you need to open her up so the truck doesn't "freak out" on the shifting and trying to figure out which fuel map to run
Reply With Quote Quick reply to this message
  #9  
Old 11-13-2009, 11:52 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 570
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by TwinTurboStroker View Post
I would re-load the tune and hammer down on it, remember this truck learns your driving style and every now and then you need to open her up so the truck doesn't "freak out" on the shifting and trying to figure out which fuel map to run
I will try that. I might go back and try the 310NZL tune and see how it works out, I haven't ran it much.
Reply With Quote Quick reply to this message
  #10  
Old 11-13-2009, 03:31 PM
Powerstroke.org Sponsor



 

Join Date: Dec 2008
Location: Georgia
Posts: 8,769
Thanks: 4
Thanked 12 Times in 11 Posts
Feedback Score: 0 reviews
Are you doing the suggested relearn process on the TCM before you start driving the truck normal?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:00 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors