275 question - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 08-06-2009, 03:02 PM Thread Starter
Member
 
Join Date: Dec 2007
Location: St.George Utah
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
275 question

My truck started smoking a lot this past month when I get on the throttle. There is a lag until the turbo spools up and then I get power but until the turbo spools I smoke like a train without any power. (3-4 seconds of a whole lot of black) Is it the summer temps causing this or do I need to reload the tune? Running the 275 version 3 and I've never even loaded the other tunes. Does version 4 remedy this by chance?
judd6854 is offline  
post #2 of 4 Old 08-06-2009, 05:09 PM
Compression Ignition Addict


 
08stroker250's Avatar
 
Join Date: Dec 2008
Location: Georgia
Posts: 8,819
Thanks: 5
Thanked 17 Times in 16 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Try reloading. The v4 could help, but it is rail pressure fix tune. It's a free tune though, so it would be worth it to get it anyway. You should not have that much turbo lag....hear does make the smoke thicker for sure, but I wouldn't think it would cause that much turbo lag...

Jeff Dodd
spartan_jeff12@yahoo.com

2012 Ford F-250 Lariat CC/SB

Mods - Spartan tuned via laptop, 4" AFE stainless exhaust system, 2.5" PMF BMC leveling spacers, 3" PMF lift blocks, Fox Racing 2.0 shocks, Recon smoked mirror & cab lights
08stroker250 is offline  
post #3 of 4 Old 08-07-2009, 05:39 AM
Premium Member
 
boostd6.4's Avatar
 
Join Date: Apr 2008
Posts: 375
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by judd6854 View Post
My truck started smoking a lot this past month when I get on the throttle. There is a lag until the turbo spools up and then I get power but until the turbo spools I smoke like a train without any power. (3-4 seconds of a whole lot of black) Is it the summer temps causing this or do I need to reload the tune? Running the 275 version 3 and I've never even loaded the other tunes. Does version 4 remedy this by chance?
With the less dense air we are all adding more unburnt fuel in the warmer months, thus more smoke....

Definitly try a reflash or an upgrade.

Mike

08 F-350 CC DUALLY LARIAT
6.4 LITER DIESEL

Soon for sale, all stock.
boostd6.4 is offline  
post #4 of 4 Old 08-07-2009, 06:18 AM
Member
 
Join Date: Jul 2007
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine did the same thing and it didnt matter what tune it was on or even stock turned out i had a broken egr ford replaced and all is well
Bansheestang is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome