Code P040D - Ford Powerstroke Diesel Forum
6.4L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-27-2009, 04:38 PM
Member
 

Join Date: Dec 2007
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Code P040D

I have a Job 1 2008 Powerstroke with about 43K miles on it. I just installed the Spartan 210 and have about 800 miles on it. I got the code P040D(Exhaust Gas Recirculation Temperature Sensor A) High. I added an AFE drop in air filter about 20K ago. No other mods. What does this mean and what should I do about it?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-27-2009, 04:59 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Posts: 214
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have the same code and so far i think its the egr temp sensor that went bad or the up pipe sensor as john cobbs said im calling him tommorow for more info he said its an easy fix.....
Reply With Quote Quick reply to this message
  #3  
Old 07-27-2009, 08:24 PM
Powerstroke.org Sponsor



 

Join Date: Dec 2008
Location: Georgia
Posts: 8,769
Thanks: 4
Thanked 12 Times in 11 Posts
Feedback Score: 0 reviews
It's the sensor on the EGR up-pipe at the top of the motor
Reply With Quote Quick reply to this message
  #4  
Old 07-28-2009, 04:23 AM
Compression Ignition Addict
 

Join Date: Oct 2008
Posts: 214
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oh thanks for the whole up pipe and egr confusion haha os my new egr temp sensor shud take care of it ....
Reply With Quote Quick reply to this message
  #5  
Old 07-28-2009, 05:07 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: Loudon, TN
Posts: 2,039
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Drop the passenger side fenderwell and its right there in the up-pipe!
Reply With Quote Quick reply to this message
  #6  
Old 07-28-2009, 09:21 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Beaumont TX
Posts: 3,802
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by CobbsDieselPerformance View Post
Drop the passenger side fenderwell and its right there in the up-pipe!
Mine did the same thing....throws the code and no EGT readings.

Replace with OEM part John? Got a part #?
Reply With Quote Quick reply to this message
  #7  
Old 07-28-2009, 10:15 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: Loudon, TN
Posts: 2,039
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I don't have the number handy, I have only bought the one for my truck.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:51 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors