So my trannys shot..... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-31-2011, 11:25 AM
Member
 

Join Date: Oct 2010
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So my trannys shot.....

@ 64K...getting one w 12K miles from the local yard for 1300, what should I upgrade while I have the new/used tranny out??

Last edited by kboring; 03-31-2011 at 11:38 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-03-2011, 06:55 AM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,223
Thanks: 22
Thanked 73 Times in 64 Posts
Feedback Score: 4 reviews
make sure you're getting one from a diesel. torqshift from a gas engine is different
Reply With Quote Quick reply to this message
  #3  
Old 04-03-2011, 06:57 AM
Compression Ignition Addict

 

Join Date: Apr 2011
Location: Palmetto, Ga
Posts: 3,395
Thanks: 1
Thanked 12 Times in 12 Posts
Feedback Score: 3 reviews
How did it go
Reply With Quote Quick reply to this message
  #4  
Old 04-07-2011, 07:08 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Illinois
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
why not done under warranty?
Reply With Quote Quick reply to this message
  #5  
Old 04-07-2011, 07:21 AM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Oil patch, North Dakota
Posts: 664
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
can never go wrong with fresh fluid and filter and maybe a bigger cooler, what were you doing to your truck to make it go out in 64k??
Reply With Quote Quick reply to this message
  #6  
Old 04-07-2011, 08:12 AM
Member
 

Join Date: Oct 2010
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well to make a long story short I had Shell Rapid Lube do a tranny flush at about 63K and they put regular dex III in the truck and it killed it.
Reply With Quote Quick reply to this message
  #7  
Old 04-07-2011, 08:15 AM
Powerstroke.org Rookie
 

Join Date: Nov 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by kboring View Post
Well to make a long story short I had Shell Rapid Lube do a tranny flush at about 63K and they put regular dex III in the truck and it killed it.
Are they paying for it because they put the wrong stuff in it?
Reply With Quote Quick reply to this message
  #8  
Old 04-07-2011, 08:21 AM
Don't you worry about it

 

Join Date: Jan 2008
Location: North Carolina
Posts: 5,544
Thanks: 2
Thanked 57 Times in 51 Posts
Feedback Score: 0 reviews
mine has been acting a little weird lately and it makes me a little nervous. The other day I put it in reverse and went to go and it was like it was in neutral but when I looked down at the selector it was in Reverse and as soon as I looked at it it engaged roughly.
Reply With Quote Quick reply to this message
  #9  
Old 04-07-2011, 12:15 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Oil patch, North Dakota
Posts: 664
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
What a bunch of morons, one more reason i like to do as much of my own wrenching as i can!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors