vents not working - Ford Powerstroke Diesel Forum

6.4 Powerstroke Interior Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 05-27-2012, 06:13 PM Thread Starter
Powerstroke.org Rookie
 
bmills618's Avatar
 
Join Date: Jan 2012
Location: 10 minutes outside st. louis
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
vents not working

i have an 08 f250 and for some reason the top blowers are not working when i turn on the a/c. i hit the switch that switches to blow on your feet and defrost and it skips right over the top vents. works just fine blowing on your feet and defrost but the switch won't let me put it on the top vents. any suggestions
bmills618 is offline  
post #2 of 6 Old 06-15-2012, 07:06 PM
Member
 
Beef Supreme's Avatar
 
Join Date: Jun 2012
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Is max a/c (a/c and recirc) selected when this is happening? I know that sounds weird, but that happened to me on my dad's '09 powerstroke and my '11 mustang.
Beef Supreme is offline  
post #3 of 6 Old 06-15-2012, 07:20 PM
Compression Ignition Addict
 
srjd's Avatar
 
Join Date: Nov 2008
Location: Ontario
Posts: 1,638
Thanks: 2
Thanked 9 Times in 9 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
I've heard something about a blend door not working if that's the problem I think the dash has to be taken apart

01/07 Job 1 F350 H&S Tuned. ARP Studs, AFE 4'' straight pipe, EGR delete with elbow, AFE stage 2 CAI, 6'' lift on 37s, 20x12 Fuel Nuts two piece, Sinister coolant filter, CCV Mod, Projector headlights HID kit
srjd is offline  
post #4 of 6 Old 06-16-2012, 04:55 PM
Compression Ignition Addict
 
blackcloud2k's Avatar
 
Join Date: Nov 2009
Location: Fort Collins, CO
Posts: 2,107
Thanks: 2
Thanked 8 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to blackcloud2k Send a message via Yahoo to blackcloud2k
Ive heard of them blowing hot air while on AC and needing to replace the blend motors, but never seen it skip over a function.

2015 F350 Ruby Red Platinum, SRW CCLB, Color matched Ranchhands, rigids.


SOLD:
blackcloud2k is offline  
post #5 of 6 Old 06-16-2012, 05:40 PM
Member
 
Beef Supreme's Avatar
 
Join Date: Jun 2012
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Since the controller/ wiring/ motors were all working on both vehicles, I chalked it up to temp changes expanding or contracting some of the plastics, causing the blend door to randomly get stuck at the same specific point. He had the problem 3 times, and I had it for a week straight. Neither one of us have had it happen once since.
Beef Supreme is offline  
post #6 of 6 Old 06-19-2012, 02:33 PM Thread Starter
Powerstroke.org Rookie
 
bmills618's Avatar
 
Join Date: Jan 2012
Location: 10 minutes outside st. louis
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
the a/c works good just skips the top blowers when i press the control for feet, knees, n top blower. guess i will dig into it this weekend.
bmills618 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome