HVAC buttons not all are lit - Ford Powerstroke Diesel Forum
6.4 Powerstroke Interior Discussion Forum Sponsored by: Husky Liners

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-22-2010, 10:53 AM Thread Starter
Powerstroke.org Fanatic
Join Date: Jun 2008
Location: Northwest Mississippi
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HVAC buttons not all are lit

I noticed for the first time today that when the lights are on only the first three buttons on the row of HVAC controls actually are lit. The recirculation, upper vent, and AC button have no lights. Has anyone else had/have this problem? By the way I dont have heated seats so I dont have the two red seat buttons.

10' F350 CC SRW LWB 6.4, Green 4x4....stock for now.
Doozer is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome