High Boost, Low Power - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 03-28-2009, 05:26 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
High Boost, Low Power

Need Help!

I bought a 2008 6.4 4x4, long bed in Sept 08. The truck has 16,600 miles on it and has rarley given trouble until now. I took it on a 3,000 mile trip. When I left, the truck was running great. On the way back, the boost was running around 25-30 psi while pulling a 7x16 enclosed trailer loaded with our hunting gear. My fuel mileage dropped to about 9mpg and the truck felt like it has a loss of power. Also, after driving at highway speeds, exiting of the interstate and starting again, the truck will not "go" when I step on the gas pedal (not in regen)! Now the boost gauge is almost always pulling 20 - 35 lbs of boost with no load.

I have had it to the dealer with no luck! The SM tells me to not worry about the boost gauge "they all do that" and also said he contacted a Ford engineer who said that "it is typical for a diesel to lose power like that". I know neither one of these are correct.

The truck is stock woth no mods, any similar problems or possible solutions?

Thanks
Andy
raefird is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-29-2009, 08:47 AM
Compression Ignition Addict
 
Greenhorn Diesel's Avatar
 
Join Date: Feb 2008
Location: Worthington, PA
Posts: 379
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by raefird View Post
Need Help!

I bought a 2008 6.4 4x4, long bed in Sept 08. The truck has 16,600 miles on it and has rarley given trouble until now. I took it on a 3,000 mile trip. When I left, the truck was running great. On the way back, the boost was running around 25-30 psi while pulling a 7x16 enclosed trailer loaded with our hunting gear. My fuel mileage dropped to about 9mpg and the truck felt like it has a loss of power. Also, after driving at highway speeds, exiting of the interstate and starting again, the truck will not "go" when I step on the gas pedal (not in regen)! Now the boost gauge is almost always pulling 20 - 35 lbs of boost with no load.

I have had it to the dealer with no luck! The SM tells me to not worry about the boost gauge "they all do that" and also said he contacted a Ford engineer who said that "it is typical for a diesel to lose power like that". I know neither one of these are correct.

The truck is stock woth no mods, any similar problems or possible solutions?

Thanks
Andy
I would ask to talk to the Ford field service engineer himself. They won't give you the number most likely, but will have him call you. Tell him your concerns and see what he does have to say. Your dealer may be a so perhaps try a different dealer. I had a dealer that was worthless, and then I switched to one that was closer, and had a dedicated truck shop so they really know what they are talking about.

Brad

2008 Ford F-350 XLT CC, LB, DRW, Job1 updated to Job3, 4.10 gears, 6.4L Powerstroke, White/Pueblo Gold, DeeZee Stainless steel elite cab boards, Spartan tuned(150dpf enables, 150, 210), Flo-Pro DOC/DPF delete AFE Pro Guard 7 both from Cobb's diesel
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, B&W turnover ball hitch, cody cushion , Cobra CB with co-phased Silverload 4' whips,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Greenhorn Diesel is offline  
post #3 of 9 Old 03-29-2009, 08:53 AM
Member
 
Join Date: Dec 2007
Location: Somewhere in Alberta
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Have them check out your dpf...might be getting clogged.
rollthecoal is offline  
post #4 of 9 Old 03-29-2009, 12:42 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks for the info. I'll give it a try!
raefird is offline  
post #5 of 9 Old 03-29-2009, 07:34 PM
Powerstroke.org Fanatic
 
Join Date: Feb 2009
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Spartanize it and drop the DPF
Fastford is offline  
post #6 of 9 Old 03-30-2009, 03:30 PM
Powerstroke.org Rookie
 
Join Date: Feb 2009
Location: Littlestown, Pa.
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Was it raining or humid? If so have them do the TSB for the lack of power / white smoke on mod to heavy tip in after driving 20+ mins.

Mine is scheduled for next Tuesday for this fix.

08 350 SRW, XLT CC LB, Camper/tow pkg, Cold pkg, Rear slider, Bed step and extender, 3.73 limited slip, 5k SuperSprings , Piaa lamps, recon interior lights.
09 Rpator 361LEV toyhauler w/ 3 road race bikes, avg load 15.5k lbs.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Landshark is offline  
post #7 of 9 Old 03-30-2009, 08:15 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Re: Landshark

Thanks Landshark, do you have a TSB number?
raefird is offline  
post #8 of 9 Old 03-30-2009, 08:17 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sorry, do you have a TSB number or should they know what I am talking about?

It did happen when it was raining but it has happened a few times during dry weather!
raefird is offline  
post #9 of 9 Old 03-31-2009, 06:07 AM
Powerstroke.org Rookie
 
Join Date: Feb 2009
Location: Littlestown, Pa.
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by raefird View Post
Sorry, do you have a TSB number or should they know what I am talking about?

It did happen when it was raining but it has happened a few times during dry weather!
TSB 08-25-1

08 350 SRW, XLT CC LB, Camper/tow pkg, Cold pkg, Rear slider, Bed step and extender, 3.73 limited slip, 5k SuperSprings , Piaa lamps, recon interior lights.
09 Rpator 361LEV toyhauler w/ 3 road race bikes, avg load 15.5k lbs.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Landshark is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome