6.4 sounds like its sucking air - Ford Powerstroke Diesel Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 04-13-2014, 10:38 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.4 sounds like its sucking air

my 6.4 sounds like its either sucking or blowing air when I accelerate under a load, and I have virtually no turbo boost. EGR and DPF delete with SCT tuner. HELP
sgwjmstx is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 04-13-2014, 10:59 AM
Powerstroke.org Fanatic
 
Join Date: Dec 2013
Posts: 143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 11 Times in 11 Posts
Feedback Score: 2 reviews
Sounds exactly like my problem. See my post in another section, here's the link:

Full DPF and EGR delete - suddenly some sort of exhaust leak

Lots of good advice there. Good luck
mhutch2 is offline  
post #3 of 17 Old 04-13-2014, 11:16 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
where is the up pipe, any pics anywhere you know of?
sgwjmstx is offline  
post #4 of 17 Old 04-13-2014, 11:28 AM
Powerstroke.org Fanatic
 
Join Date: Dec 2013
Posts: 143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 11 Times in 11 Posts
Feedback Score: 2 reviews
Here is a pic of the engine with the cab lifted. The rusty looking pipe you see on right of the pic is the driver's side up pipe that runs from behind the turbo to the EGR cooler. When you delete the EGR the pipe is no longer supported and tends to crack at the bellows. That's what happened to mine.

Apparently, one can remove that pipe and relocate the EBP sensor, however, I can't seem to fit my hands back there so there must be a trick to it.
Attached Thumbnails
Click image for larger version

Name:	powerstroke engine.jpg
Views:	3605
Size:	76.7 KB
ID:	272945  
mhutch2 is offline  
post #5 of 17 Old 04-13-2014, 04:02 PM
Compression Ignition Addict
 
sanman28's Avatar
 
Join Date: Jul 2011
Location: SWMO
Posts: 585
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 5 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by mhutch2 View Post
Here is a pic of the engine with the cab lifted. The rusty looking pipe you see on right of the pic is the driver's side up pipe that runs from behind the turbo to the EGR cooler. When you delete the EGR the pipe is no longer supported and tends to crack at the bellows. That's what happened to mine.

Apparently, one can remove that pipe and relocate the EBP sensor, however, I can't seem to fit my hands back there so there must be a trick to it.
This happened to mine too. Whistle noise under load and higher RPM's.



2010 CCSB FX4. Mini Maxx/Gearhead, Deletes, H11 Studs, Up-pipes, 4" DP, 5" Back, CAC, Elbow, CCV, CAI, Custom Heads, Elite Transmission


FBHO
sanman28 is offline  
post #6 of 17 Old 05-24-2014, 06:22 PM
Powerstroke.org Fanatic
 
Join Date: Sep 2009
Location: Chicago
Posts: 109
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had a dpf delete on my 08 last sept. I am now experiencing this sucking sound. I sounds like its coming from right behind the turbos.


2008 F450 w/Century 311. DPF/EGR delete. Spartan tuned.
2003 Grand Marquis..some mods...
jasong145 is offline  
post #7 of 17 Old 05-24-2014, 07:09 PM
Compression Ignition Addict
 
JD_MILLS's Avatar
 
Join Date: Apr 2011
Posts: 505
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Could be the up pipe leaking. Check around the firewall it'll probably have soot on it if they are. Mine was covered when my left one went out.


2008 f-250 LARIAT, SCT LIVEWIRE, S&B CAI, 8" MBRP STACK
JD_MILLS is online now  
post #8 of 17 Old 05-25-2014, 01:03 AM
Powerstroke.org Fanatic
 
Join Date: Sep 2009
Location: Chicago
Posts: 109
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Seems when im cruising and there is low boost there's barely any noise. As soon as I build boost thats when I hear the air noise. Bad pipe?


2008 F450 w/Century 311. DPF/EGR delete. Spartan tuned.
2003 Grand Marquis..some mods...
jasong145 is offline  
post #9 of 17 Old 05-25-2014, 02:14 AM
Member
 
mprc911's Avatar
 
Join Date: May 2009
Location: Springfield, Tn
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
My 6.0 was doing the same thing. Had a 6 inch crack in the plastic pipe from the intercooler to the intake elbow.
mprc911 is offline  
post #10 of 17 Old 05-25-2014, 03:05 AM
Powerstroke.org Fanatic
 
Join Date: Sep 2009
Location: Chicago
Posts: 109
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So heres the question...is any harm done if I drive like this for a bit? The truck is driving fine. Just the pshhhhh noise


2008 F450 w/Century 311. DPF/EGR delete. Spartan tuned.
2003 Grand Marquis..some mods...
jasong145 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome