Motor problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-24-2014, 10:46 AM
Powerstroke.org Rookie
 

Join Date: Feb 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Motor problems

I have an 08 6.4l with 180k on it. Heat in cab not good, turbo psi is at 10 when going down the highway not pulling anything and goes up to 20 or 30 on a slight incline or if I'm going from a stop up to speed with 1/2 throttle it's up there also some times goes to 40, very heard on fuel right now. Anyone have these problems and might have a solution
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-17-2014, 01:31 PM
Member
 

Join Date: Oct 2012
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check tube the ebp sensor. Mine snapped and was doing this. Could be plugged
Reply With Quote Quick reply to this message
  #3  
Old 03-17-2014, 04:00 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2014
Posts: 120
Thanks: 2
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
try removing and clean the MAP sensor, they get carboned up. Its the 27mm 3-pin sensor on passenger side on the intake manifold right by when the air intake meets the turbo. I usually use a very thin phillips screwdriver and some pb blaster, but that hole in the sensor goes pretty deep
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:38 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors