EGR sensor?? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-22-2014, 08:56 AM Thread Starter Fanatic
Join Date: Feb 2009
Location: Alma, Colorado AND Independence, Iowa
Posts: 107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
EGR sensor??

The shop that deleted my EGR (stopped major coolant loss) left sensor attached to wiring loom. Now my CEL comes on. I am able to clear it via my Black Max tune...but the code is "Turbo boost performance system". Could only get 20# pulling #18k TOYHAULER up the mountains heading for home. Am I losing a turbo OR is the computer getting a false reading??? THX in advance. Johnny
IOWASTROKER46 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome