P2452 Help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-11-2013, 07:46 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
P2452 Help

Ok,
I will try to explain and hopefully one or several of you smarter people can give me some advice.

Today I had to replace my EGR and housing. I am not mechanically inclined so the ford dealer did it which ran me $1300

The truck drove fine today but not as powerful as it used to be.

I am running an AFE CAI
Spartan tune ( I believe the 175)
4" straight pipe from down tube back.

I drove about 35 miles today and on my way home the CEL came on. Pulled into the drive and read the code P2452.

Why would this happen?
and
How do I fix it.

So, this is what I am thinking, clear the code and reload the tune
or
just clear the code.

But that still doesn't explain the lack of performance.

Thank you for any advice
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-12-2013, 12:23 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update

So,
This might help someone else that has an issue with this code. Today I drove the truck with CEL on at first no issues but once the motor warmed up. I drove about 10 miles in the city lots of stop and go. I noticed it was blowing a lot of white smoke. I mean a lot. Pulled over at the park and let the dog run 20-30 minutes. Fired the truck back up and 5 minutes of driving it started smoking again. At idle and under load. I also notice I was using a lot of fuel. I could almost see the fuel gauge go down as long as the truck was running. Drove to locale dealership and talked with them. I have an appointment with them in the morning and they will take a look. I brought the truck home. It drives fine, didn't go into limp mode just blows a ton of white smoke, and using a lot of fuel. Almost like the vehicle was going into regen mode. Came home reloaded my tune, the code is gone and no more white smoke. Truck feels like more power. I will do a longer drive and give you guys an update.

I am looking for any advice or concerns I should have with this.
Thank you for any help or advice
Reply With Quote Quick reply to this message
  #3  
Old 11-16-2013, 03:19 AM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would think you might need to reload your tune. You shouldn't get that code with your tune.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors