Turbo issue on '08 6.4L - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-07-2013, 02:19 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Leduc, Alberta
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo issue on '08 6.4L

Appears we have a turbo leak, the Ford dealer claims this is a "normal" problem to occur.

Anyone else witness this? Is it as simple as replacing the necessary gaskets, or does the turbo itself need replacing?

What other "normal" issues shall I expect with this truck in the next little while? I need this thing to stay on the road for the next month, after that I plan to burn it.

It currently has 135,500 kms on it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-23-2013, 04:31 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Posts: 407
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had this situation on my 08 at 90k miles. When we got in there the #1 turbo was shot. Ended up replacing the turbo and all of the gaskets. Runs great now!
Reply With Quote Quick reply to this message
  #3  
Old 10-24-2013, 06:37 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2012
Location: Renfrew, Pa (near Pittsburgh)
Posts: 105
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How did you know you had a turbo leak?

Could you hear it?

Any loss of power?

Any loss of boost?
Reply With Quote Quick reply to this message
  #4  
Old 10-24-2013, 09:05 AM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Leduc, Alberta
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The Y pipe was the fault, this is what they claimed as a "normal" issue. Yes it could be heard, no loss of power.
Reply With Quote Quick reply to this message
  #5  
Old 10-24-2013, 02:49 PM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,311
Thanks: 15
Thanked 68 Times in 66 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Tyler Williams View Post
The Y pipe was the fault, this is what they claimed as a "normal" issue. Yes it could be heard, no loss of power.
That's not a turbo issue. leaking up pipes are fairly common on stock and tuned trucks. Has to do with back pressure.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:07 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors