Turbo issue on '08 6.4L - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-07-2013, 01:19 PM Thread Starter
Powerstroke.org Rookie
 
Tyler Williams's Avatar
 
Join Date: Jun 2009
Location: Leduc, Alberta
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Turbo issue on '08 6.4L

Appears we have a turbo leak, the Ford dealer claims this is a "normal" problem to occur.

Anyone else witness this? Is it as simple as replacing the necessary gaskets, or does the turbo itself need replacing?

What other "normal" issues shall I expect with this truck in the next little while? I need this thing to stay on the road for the next month, after that I plan to burn it.

It currently has 135,500 kms on it.
Tyler Williams is offline  
post #2 of 5 Old 10-23-2013, 03:31 PM
Compression Ignition Addict
 
Join Date: Mar 2009
Posts: 407
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I had this situation on my 08 at 90k miles. When we got in there the #1 turbo was shot. Ended up replacing the turbo and all of the gaskets. Runs great now!
BlueF350 is offline  
post #3 of 5 Old 10-24-2013, 05:37 AM
Powerstroke.org Fanatic
 
barlowchiro's Avatar
 
Join Date: Aug 2012
Location: Renfrew, Pa (near Pittsburgh)
Posts: 116
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
How did you know you had a turbo leak?

Could you hear it?

Any loss of power?

Any loss of boost?

2008 SB CC KR 6.4L Job 1
AFE CAI
EGR Delete
5" DPF Delete
4" DP
MBRP Passenger Side IC Pipe
H&S Mini MAXX
2.5" Ready Lift Leveling Kit
35x12.5x20 Toyo Open Country MTs w/ stock KR wheels
AMP Research Power Steps
Coming Soon: CCV Mod, Air Dog II
barlowchiro is offline  
post #4 of 5 Old 10-24-2013, 08:05 AM Thread Starter
Powerstroke.org Rookie
 
Tyler Williams's Avatar
 
Join Date: Jun 2009
Location: Leduc, Alberta
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The Y pipe was the fault, this is what they claimed as a "normal" issue. Yes it could be heard, no loss of power.
Tyler Williams is offline  
post #5 of 5 Old 10-24-2013, 01:49 PM
Compression Ignition Addict
 
04hdfatboy's Avatar
 
Join Date: Oct 2010
Posts: 4,614
Thanks: 16
Thanked 95 Times in 93 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Tyler Williams View Post
The Y pipe was the fault, this is what they claimed as a "normal" issue. Yes it could be heard, no loss of power.
That's not a turbo issue. leaking up pipes are fairly common on stock and tuned trucks. Has to do with back pressure.

08 F350 cc/sb 4X4
h&s minimaxx, 5" flo pro, 4" down pipe, no limit cold air intake, dirty diesel EGR delete with intake elbow, 6.0 exhaust manifolds, custom up pipes, ported intake manifold, Apex 71mm LP turbo, Rudy's cold side pipe, diesel site coolant and transmission filter, diesel site intercooler boots, ccv mod, bilstein shocks, gogo dd solenoid, HID lights, Airdog II 165, PMF traction bars, PMF drag link, moshimoto aluminum radiator
04hdfatboy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome