08 f350 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-17-2013, 04:04 PM
Member
 

Join Date: Jun 2012
Posts: 79
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
08 f350

Hi guys. just looking for advice. my truck lately has been getting a wrench light after driving about 40 miles in very hot weather. I have a livewire 9625 xtreme. I haven't tuned truck yet but thought id scan gauges while I went to work in morning and after work. in the morning it was only 10 degrees Celsius and temp deltas were around 8 degrees and no light. two mornings in a row. today with the tuner watching on the way home, I got a wrench light. I was really watching the temps. it was around 27 degrees Celsius, 40 mile drive home. deltas were sitting right around 15 degrees and suddenly out of the blue 90% of the way home, the coolant temp dropped 2 degrees f. and right then the wrench light came on. It was a 17 degree difference. should I be alarmed????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-18-2013, 05:24 AM
Premium Member
 

Join Date: Mar 2011
Location: Great Falls, VA
Posts: 828
Thanks: 1
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
are you running Canned tunes that came with it? or are you running custom tunes from a tuning company?

when you're loading the tunes onto your truck, when the option comes up if you have "disabled the EGR" you should be selecting yes, even if its still on your truck. I ran into this issue when i first installed my livewire. also, oil temp read out is in Celcius if you didn't know that. hope this helps.
Reply With Quote Quick reply to this message
  #3  
Old 09-18-2013, 06:23 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,023
Thanks: 13
Thanked 38 Times in 37 Posts
Feedback Score: 0 reviews
Are you talking about the spread between your ECT and EOT? If so that means your oil cooler is getting plugged.
Reply With Quote Quick reply to this message
  #4  
Old 09-18-2013, 03:24 PM
Member
 

Join Date: Jun 2012
Posts: 79
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yea. Thats what i was talking about. Then today drove same trip home 45 miles but in 15 degree celsius weather and no light. Only when its really hot out
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors