Beating head on wall can't figure it out. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-12-2013, 02:46 PM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Location: Tomball, Tx
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Beating head on wall can't figure it out.

Need a little help guys. First off I have a 2008 6.4 with a min max tuner, afe intake, DPF delete, and EGR valve/cooler delete. While towing my camper started leaking exhaust pre-turbo. I towed the camper about 100 miles to make it home. Found down pipe expansion joint cracked. I deleted the down pipe and moved exhaust pressure sensor.

After the repairs I've been having some drivability problems and can't wrap my head around what's going on.

Overall truck has lost power and lower mpg... feels like shes dragging an anchor. While towing I am seeing higher than normal exhaust temp and lower boost. Checked KOEO exhaust pressure sensor showing 3 psi. Exhaust and boost pressure are within 6 psi of each other. Boost seems normal up to 20 psi and is very slow to respond over 20. After 20 psi it seems like there is a lot of lag and slow to build pressure. Curious if anyone has any thoughts on what could be causing this issue. Please help!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-13-2013, 07:16 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 3,760
Thanks: 7
Thanked 19 Times in 18 Posts
Feedback Score: 0 reviews
Take off and clean or replace the map sensor and ebp sensor. So do you still have the ebp tube or did you drill and tap the block off plate?
Reply With Quote Quick reply to this message
  #3  
Old 09-13-2013, 02:39 PM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Location: Tomball, Tx
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've cleaned both MAF and EBP sensor. I installed new tubing so I would have to splice longer wire.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
6.4 bad turbo, 6.4 egr, 6.4 exhaust, 6.4 mods, 6.4 motor problems

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:26 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors