08 6.4Diesel No Start, wants too, though doesn't - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-13-2013, 06:08 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jul 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
08 6.4Diesel No Start, wants too, though doesn't

Hello, this is my first post - My 6.4 has been down for 2 months, started with misfires, found broken rockers, ruined my head, replaced head, new turbos DPF Delete, egr delete, added a H&S programmer, took it out made it almost back home from going for 100 mile trip - started up a slight incline and the boost skyrocketed to 40 psi and a CAC boot came off - got towed home and found I lost High pressure fuel - checked low side have 3-5 psi - checked wiring replaced FRP sensor - new filters and changed the oil - now have changed the high pressure fuel pump and it acts like it will start though just goes into a extended crank - it acts like it firing, though doesn't start. Do have glow plug codes for #3 & #5, though that surely doesn't effect starting on a 102 degree day does it?
buytires is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome