missing a sound from my 08 6.4 that's effecting turbo psi - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-17-2013, 06:25 AM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
missing a sound from my 08 6.4 that's effecting turbo psi

Hello everyone, I have a 08 f350 6.4psd and I'm having an issue with a missing sound either from my engine or turbo. My engine or turbo use ta make this grow like sound and whooshing sound on the initial acceleration. When I use to have this sound it would cut in just as you first begin to accelerate and cut out at around 2,000 rpm, and the turbo psi would be at 20 all the way thru the gears if you held it at 2000 rpm. Well the sound has disappeared and now at 2000 rpm its only getting 10 psi all way thur gears, holding it at 2000 rpm, I've had it to 4 dealers now over the past 4 months and they have no idea what it is, sometimes that sound will come back here and there and when it does all works fine, anyone have this experience, the dealers have no other 6.4 in their lots to even do a sound comparrison thanks
mohawk2 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome