Died on road again - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-01-2013, 07:19 AM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: La
Posts: 420
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Died on road again

Here we go again. Coming home from going out last night, thr truck lost power, I wasn't driving at the time my girl was. so i don't know if any warning came up on the dash, I tried to tell her not to stop but when she did it DID. Can't do anything except take it out of gear. Last time this happened I coulddn't even take it out of drive. and it was a exhaust sensor. Not sure what it is now, I got it towed to my house. If i get a scanner tool do yall think it will give me possible codes?? any ideal on where to start, Once i got home i went to bed and than came to work so i haven't even looked at it Did want to even see it this morning. any clues???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-01-2013, 08:00 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Posts: 1,706
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
Not much we can help you with without codes
Reply With Quote Quick reply to this message
  #3  
Old 03-01-2013, 02:05 PM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: La
Posts: 420
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
All I know right now is she said the battery light came on before it died.
Reply With Quote Quick reply to this message
  #4  
Old 03-01-2013, 05:27 PM
Compression Ignition Addict
 

Join Date: Jan 2013
Location: O'Fallon, Missouri
Posts: 169
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
How old are batteries? Maybe time to replace them???
Reply With Quote Quick reply to this message
  #5  
Old 03-02-2013, 05:25 AM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: La
Posts: 420
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
They aren't that old, maybe 1.5 yrs. Red top optimax. What's a good scanner tool to get? Haven't had time to do much but dis connected the batteries
Reply With Quote Quick reply to this message
  #6  
Old 03-03-2013, 11:30 AM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: La
Posts: 420
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok I pulled the code. P0087, fuel rail/system pressure too low. What does this mean. How can I fix this?
Reply With Quote Quick reply to this message
  #7  
Old 03-03-2013, 11:34 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Posts: 1,706
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
Sounds like a hpfp problem. When was the last time your fuel filters were changed? Could be the hpfp wiring harness shorting
Reply With Quote Quick reply to this message
  #8  
Old 03-03-2013, 12:16 PM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: La
Posts: 420
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Filters are changed often. Where is the hpfp.Is this something the dealer need to do.? Or can I do this myself?
Reply With Quote Quick reply to this message
  #9  
Old 03-03-2013, 01:08 PM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: La
Posts: 420
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok I want say ford changed that out at about 95k. They changed the injector pump? Is that the hpfp? I had no issues with the truck as for as performance. I cleared the code and it did actually crank but not for long. Didn't start but now its not doing anything if not I'm looking at $$$$$ I guess I'll have to get it to ford this week
Reply With Quote Quick reply to this message
  #10  
Old 03-03-2013, 06:01 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Posts: 1,706
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
The HPFP is the high pressure fuel pump. yes injection pump. If you had no performance issues, it may be the wiring to the hpfp under the valve cover shorted out. And you may need to change the filters yourself, Ive pulled out filters that were "changed" at ford every 10k miles and a 50k mile truck wouldnt run so I changed them for the guy and it looked like the ones that came off the lot with it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:25 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors