2010 6.4 With 3 problems, Need help cause dealer is none - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-06-2013, 04:26 PM
Premium Member
 

Join Date: Jul 2012
Location: Philadelphia
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 2010 6.4 With 3 problems, Need help cause dealer is none

I have a 2010 F350 6.4 with 67,000 miles. I have an H&S mini max, DPF delete, 4" Exhaust. 2 months ago was towing my mini excavator up a hill and the truck lost power then the engine light came on. Scanned it and it was #2 cylinder contribution and some type of turbo over boost or turbo code? I cleared the codes, no more engine light but #2 cylinder code still showing on my tuner, no more turbo code though. Truck seemed normal until I pulled a hill with an empty trailer, seem to lose 25% to 35% of it power and stay that way till i pulled over and restarted truck. Dealer was no help cause engine light wasn't on, they told me prob the injector but not sure cause the couldn't verify the code. Been driving it but haven't towed anything cause If it is injector I didn't want to overheat cylinder. Thats my first problem. Sunday i was running hard up a hill and when i let off throttle engine light came on, trans temp dropped out and fan came one all at the same time. Pulled over pulled codes and came up with Fan speed sensor and a Trans sensor. I cleared them hoping it was a freak thing and it seem to work for a few mile then it happened again. Parked the truck came back an hr later same deal good for a few miles then engine light, no reading on Trans temp and fan was running all the time. Took it in, the dealer drops pan to check sensor and change fluid calls me and tells me they cant verify the code again cause of the chip but this time check engine light was on so I don't get it? Oh and they forgot about fan sensor code and when I reminded them and asked them why it happened at the same time and if they might be related I got a long pause and a stupid answer to a good question. I am done trying to save alittle time and have someone else fix it. I am mechanically inclined and no how to work a wrench I just need some help figuring out where to start. Can you guys please help before I go back to a V-10!!!??? Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-06-2013, 04:28 PM
Premium Member
 

Join Date: Jul 2012
Location: Philadelphia
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
And sorry it was so long, I just wanted to be as discriptive as possible
Reply With Quote Quick reply to this message
  #3  
Old 02-09-2013, 06:47 AM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like 2 problems.
Swap #2 injector with the one next to it.
Do a leak down test on #2 while its out.

If you own a DVOM then test the trans sensor for an open circut.
If ok then jump across the connector ans see if the gauge pegs, or you get a differant code.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:27 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors