New injector and still misfiring - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 02-05-2013, 05:41 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
New injector and still misfiring

Hey everyone new to this fourm looking for some help. I have an 08 f350 with spartan chip running 275 tune with egr block off plates(had to valve was sticking) and it recenly started misfiring just sitting on idle showing #2 cylinder coribution/balance and #2 cylinder misfire. I brought it in and had the injector changed and it ran fine for a few hours then started doing the exact same thing #2 again. I fidured changing the tune may help so i set it to stock hp no dpf without thinking this tune doesnt account for the lack if egr but it didnt misfire at all just ran weird. Idk any idea guys thanks!
Andrewrk is offline  
post #2 of 8 Old 02-05-2013, 06:42 PM
Compression Ignition Addict
 
K1LLsW1TchEd's Avatar
 
Join Date: Oct 2010
Location: South Jersey
Posts: 400
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Run some fuel additive in there and see if it clears up.


2@@8 F250 FX4 Supercab
SCT Livewire w/IDP's Tunes
S&B Cold Air Intake
Rudy's EGR Delete w/FloTech Elbow
33" Nitto Terra Grapplers
MBRP 4"Exhaust/5" Tip and Hollowed DPF
Bilstein Shocks
Kicker Hide-Away Sub
Drilled and Slotted Rotors

Rides:
2008 F250 FX4
2005 Mazda 6
2004 F150 STX
2007 Nissan Maxima SE
Coming soon: VW GTI
K1LLsW1TchEd is offline  
post #3 of 8 Old 02-05-2013, 06:49 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yea i always run conditioner because its like -35c in the mornings where i live
Andrewrk is offline  
post #4 of 8 Old 02-05-2013, 06:56 PM
Compression Ignition Addict
 
K1LLsW1TchEd's Avatar
 
Join Date: Oct 2010
Location: South Jersey
Posts: 400
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
That cylinder might have a problem then. Hmmm


2@@8 F250 FX4 Supercab
SCT Livewire w/IDP's Tunes
S&B Cold Air Intake
Rudy's EGR Delete w/FloTech Elbow
33" Nitto Terra Grapplers
MBRP 4"Exhaust/5" Tip and Hollowed DPF
Bilstein Shocks
Kicker Hide-Away Sub
Drilled and Slotted Rotors

Rides:
2008 F250 FX4
2005 Mazda 6
2004 F150 STX
2007 Nissan Maxima SE
Coming soon: VW GTI
K1LLsW1TchEd is offline  
post #5 of 8 Old 02-05-2013, 07:34 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ugh.. i really hope not
Andrewrk is offline  
post #6 of 8 Old 02-06-2013, 03:10 PM
Premium Member
 
Join Date: Jul 2012
Location: Philadelphia
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have a 2010 and I had the same codes come up. I have the H&S mini max (which I have not been happy with cause ever since I put it in been nothing but problems. Makes me just want to take it out and put it back to stock cause everytime I bring it to get fixed they cant figure it out and use it as an accuse why they cant fix it) and I was towing my mini excavator up a hill when it first started. Milked it home with engine light on scanned it for codes and saw the same thing so I cleared them for some reason. Next morning (30 to 35 degrees out) started up fine and while letting it idle to warm up it stared blowing alot of white/grey smoke and was running broken up once the high idle kicked in. Shut it off, started back up no more smoke or breaking up. Took it out and was pulling a slight grade with an empty trailer and half way up the hill I felt like I had lost 25% to 35% of the trucks power. Brought it to the dealer and they tell me they see the #2 cylinder contribution code but cant fix it under warranty cause the engine light isn't on or figure out exactly what is wrong with the truck because technically it is not setting off the engine light. They tell me its most likely the injector but cant be sure. I have been driving the truck for 2 months like this and I am worried I am making it worse if the injector really is the problem but after reading ur post I am now really confused cause I was going to do injector myself this weekend?
Drew11474 is offline  
post #7 of 8 Old 02-06-2013, 04:48 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Today a mechanic i work with suggested i take my battery cables off and touch them together to reset the computer so i tried it. Started it up and deffinately sounds worse i let it run for about a minute and it shut itself off once it started misfiring im almost scared if it will start again or not but dont want to try.
Andrewrk is offline  
post #8 of 8 Old 02-06-2013, 05:02 PM
Hunter of Trolls


 
drewactual's Avatar
 
Join Date: Nov 2012
Location: east coast
Posts: 1,970
Thanks: 91
Thanked 175 Times in 136 Posts
Mentioned: 3 Post(s)
Quoted: 25 Post(s)
Feedback Score: 0 reviews
#2 is at the end of the rail, and it sounds like a fuel issue... Maybe air infiltration? Maybe debris in the rail? When they swapped injectors, did they bleed it properly? I'd check all the fittings and banjo bolts, reprime it, and see what happens as a starting point to figuring this out..
drewactual is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome