Lift Pump Question ?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-12-2013, 10:12 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: Baker, LA
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Lift Pump Question ??

When I turn the key on, the lift pump makes a little noise ( some light ticking) for about 20 secs, then no noise at all. is this normal, or should it be pumping non stop when the key is on ??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-12-2013, 11:06 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: Baker, LA
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
OMG !! Is the Lift pump the same thing as the HFCM ???
Reply With Quote Quick reply to this message
  #3  
Old 01-12-2013, 11:42 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Location: east coast
Posts: 679
Thanks: 1
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Ha!!! Yes, the two names the same critter...

You're golden.. the lift pump only runs for about that time during key on no start... Once it creates pressure to the hpfp it stops.. it runs continuously when engine is running..
Reply With Quote Quick reply to this message
  #4  
Old 01-12-2013, 11:44 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: Baker, LA
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not good .... I have problems, and I don't know what to do.
Reply With Quote Quick reply to this message
  #5  
Old 01-12-2013, 11:54 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Location: east coast
Posts: 679
Thanks: 1
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
What are your problems?

The pump is clearly audible with key on/no start.. its hard to hear with the engine running.. if you don't start the truck, it will only run for long enough to create pressure and then stop..

What is yours doing?
Reply With Quote Quick reply to this message
  #6  
Old 01-12-2013, 12:01 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: Baker, LA
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You can barley hear anything unless you are under the truck and then its just a little ticking sound. I don't know if its good or bad. I hope this pump is bad and not the hpfp. The truck will crank right up, but it stalls out after driving about 2 miles. I don't know what's wrong.
Reply With Quote Quick reply to this message
  #7  
Old 01-12-2013, 12:12 PM
Compression Ignition Addict
 

Join Date: Nov 2012
Location: east coast
Posts: 679
Thanks: 1
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
take the lift pump cover off and clean it really well
Reply With Quote Quick reply to this message
  #8  
Old 01-12-2013, 12:17 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Location: Baker, LA
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the help
Reply With Quote Quick reply to this message
  #9  
Old 01-14-2013, 07:47 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 3,759
Thanks: 7
Thanked 19 Times in 18 Posts
Feedback Score: 0 reviews
If the lift pump is bad you could look into an airdog 2 as a replacement.
Reply With Quote Quick reply to this message
  #10  
Old 01-14-2013, 08:17 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Location: east coast
Posts: 679
Thanks: 1
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
I 'spect his lift pump is toast.. but i'd at least try to recover it.. it may have a clogged stator or something..

fwiw, though, I installed an air dog, and I dig it.. it cost me $600 total, and about four or so hours to install... a new OE lift pump cost in the neighborhood of $450- and though it would be easier to install, if'n I were him, I'd be upgrading too..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:31 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors